加密技术应用.ppt
- 配套讲稿:
如PPT文件的首页显示word图标,表示该PPT已包含配套word讲稿。双击word图标可打开word文档。
- 特殊限制:
部分文档作品中含有的国旗、国徽等图片,仅作为作品整体效果示例展示,禁止商用。设计者仅对作品中独创性部分享有著作权。
- 关 键 词:
- 加密 技术 应用
- 资源描述:
-
单击此处编辑母版标题样式,单击此处编辑母版文本样式,第二级,第三级,第四级,第五级,PPT,文档演模板,Office,PPT,12 十一月 2026,加密技术应用,提纲,密码知识简介,对称密码体制及信息加密,非对称密码体制及CA认证,网络现状及安全问题分析,网络发展趋势,TCP/IP网络安全问题分析,VPN技术综述,MLPS、SSL/TSL、L2TP、PPTP、IPSec,IPSec VPN技术,IPSec实现机制,IPSec VPN系统的实施,第一部分,密码学基础知识,信息加密的基本模型,三要素:信息密文、密钥、信息密文,C=E,n,(K,P),现代密码学理论,“一切秘密存在于密钥之中”,密钥(K),密码分析者,进行破译分析,密码算法,信息明文(P),信息密文(C),传输或存储,Alice,Bob,Oscar,关于密码体制更严格的定义,密码体制:它是一个五元组(P,C,K,E,D)满足条件:,P是可能明文的有限集;(明文空间),C是可能密文的有限集;(密文空间),K是一切可能密钥构成的有限集;(密钥空间),任意kK,有一个加密算法e,K,E和相应的解密算法d,k,D,使得e,K,:P C和d,K,:C P分别为加密解密函数,满足d,k,(e,k,(x)=x,这里x P。,加密函数e,k,必须是单射函数,就是一对一的函数。,若P=C,则e,k,为一个置换。,好的密码算法是唯密钥而保密的。,若使用相同的密钥,这个加密体制为对称的,否则称为非对称的。,密码分析和破译,假设破译者Oscar是在已知密码体制的前提下来破译Bob使用的密钥。这个假设称为Kerckhoff原则。最常见的破解类型如下:,唯密文攻击:Oscar具有密文串y.,已知明文攻击:Oscar具有明文串x和相应的密文y.,选择明文攻击:Oscar可获得对加密机的暂时访问,因此他能选择明文串x并构造出相应的密文串y。,选择密文攻击:Oscar可暂时接近密码机,可选择密文串y,并构造出相应的明文x.,5.这一切的目的在于,破译出密钥,密码体制分类,对称密码体制:加密和解密的密码算法和密钥相同,C=E,n,(K,T)T=D,n,(K,C),E,n,、D,n,相同,K和C具有相同的样本空间,典型代表:伪随机序列、DES、RC5、RC6,非对称密码体制:加密和解密的密钥不同,C=E,n,(K,e,,T)T=D,n,(K,d,,C),K,e,、K,d,不同且不能相互推导,K和C具有相同的样本空间,典型代表:RSA、DSA、椭圆曲线,单向散列函数:作用于一任意长度的消息M,返回固定的散列值h,h=H(M)或 h=H(K,M),M的样本空间一般大于h的样本空间,典型代表:MD5、SHA,DES简介,DES利用56比特串长度的密钥K来加密长度为64位的明文,得到长度为64位的密文。分三个阶段实现:,给定明文X,通过一个固定的初始置换IP来排列X中的位,得到X,0,。X,0,=IP(X)=L,0,R,0,其中L,0,由X,0,前32位组成,R,0,由X,0,的后32位组成。,计算函数F的16次迭代,根据下述规则来计算,L,i,R,i,(,1=i=16,)Li=R,i-1,Ri=L,i-1,F(R,i-1,Ki)其中Ki是长为48位的子密钥。子密钥K,1,,K,2,,K,16,是作为密钥K(56位)的函数而计算出的。,对比特串R,16,L,16,使用逆置换IP,-1,得到密文Y。Y=IP,-1,(R,16,L,16,),一轮迭代图示,在K,i,的作用下共进行16轮迭代,L,i-1,R,i-1,F,+,L,i,R,i,K,i,DES的F函数,A=R(32 bits),J=K(48 bits),E,E(A)为48 bits,+,B,1,B,2,B,3,B,4,B,5,B,6,B,7,B,8,S,1,S,2,S,3,S,4,S,5,S,6,S,7,S,8,C,1,C,2,C,3,C,4,C,5,C,6,C,7,C,8,P,32 bits F(A,J),B,写成8个6比特串,E为32到64比特的扩展,每个Sj是一个固定的4,16矩阵,它的元素取015的整数,P为固定置换,K,i,的生产,K是长度为64的位串,其中56位是密钥,8位是奇偶校验位,PC-1为固定置换,K,PC-1,C,0,D,0,LS,1,LS,1,C,1,D,1,LS,2,LS,2,LS,16,LS,16,C,16,D,16,PC-2,PC-2,K,1,K,16,3DES,Tuchman给出双密钥的EDE模式(加密-解密-加密):,C=EK1(DK2(EK1(P)对P加密,P=DK1(EK2(DK1(C)对C解密,这种替代DES的加密较为流行并且已被采纳用于密钥管理标准(The Key Manager Standards ANSX9.17和ISO8732).,E,D,E,D,E,D,C,B,A,P,P,A,B,C,K,1,K,2,K,1,K,1,K,2,K,1,加密,解密,RSA密码体制,RSA由Rivest,Shamir和Adleman在1978年提出,数学基础是Euler(欧拉)定理,建立在大整数因子的困难性之上。实现的步骤如下:Bob为实现者,(1)Bob寻找出两个大素数p和q,(2)Bob计算出n=pq和,(n)=(p-1)(q-1).,(3)Bob选择一个随机数e(0e,(n),满足(e,,(n))1,(4)Bob使用辗转相除法计算d=e-1(mod,(n),(5)Bob在目录中公开n和e作为她的公开钥。,密码分析者攻击RSA体制的关键点在于如何分解n。若分解成功使n=pq,则可以算出(n)(p-1)(q-1),然后由公开的e,解出秘密的d。(猜想:攻破RSA与分解n是多项式等价的。然而,这个猜想至今没有给出可信的证明!),RSA实例,若Bob选择p=101和q113,那么,n=11413,(n)=10011211200;而112002,6,5,2,7,一个正整数e能用作加密指数,当且仅当e不能被2,5,7所整除(事实上,Bob不会分解(n),而且用辗转相除法(欧式算法)来求得e,使(e,(n)=1)。假设Bob选择了e=3533,那么用辗转相除法将求得:,d=e,-1,6597(mod 11200),Bob的解密密钥d=6597.,Bob在一个目录中公开n=11413和e=3533,现假设Alice想发送明文9726给Bob,她计算:,9726,3533,(mod 11413)=5761且在一个信道上发送密文5761。当Bob接收到密文5761时,他用他的秘密解密指数(私钥)d6597进行解密:5761,6597,(mod 11413)=9726,单向散列函数MD4,MD4:给定一个消息比特串x,使用如下算法来构造M:,设d=447-(|x|(mod 512),l,表示|x|(mod 2,64,)的二进制表示,|,l,|=64,M=x|1|O,d,|,l,在M的构造中。在x后面附上一个1,然后并上足够多,的0使得长度变成模512(=2,9,)与448用余的数,最后并,上64bit的,l,,它是x的长度的二进制表示。(注意:若必,要的话,用模2,64,约简)。易见,512|1M。将M表示成阵列形式:M=M0M1MN-1,其中每一个Mi是一个长度为32bit的串且N,0(mod/6),我们称每一个Mi为一个字。,消息摘要的构造,构造关于x的128bit的消息摘要的算法描述如下:,1给出寄存器A,B,C,D,第一步初始化:,A=67452301(16进制),B=efcdab89(16进制),C=98badcfe(16进制),D=10325476(16进制),2对i=0到N/16-1做:,3对j=0到15做Xj=M16i+j每次处理陈列M的16个字!,4AA=A,BB=B,CC=C,DD=D,5轮1;,6轮2;,7轮3;,8A=A+AA,B=B+BB,C=C+CC,D=D+DD,消息摘要为A|B|C|D128bits!,数字签名与验证,数字签名随文本的变化而变化,而手写签字反映某个人的个性特征,是不变的;,数字签名与文本信息是不可分割的,而手写签字是附加在文本之后的,与文本信息可以是分离的。数字签名机制提供了一种鉴别方法,以解决伪造、抵赖、冒充和篡改等安全问题。,采用一种数据交换协议,使得收发数据的双方能够满足两个条件:,接收方能够鉴别发送方所宣称的身份;,发送方事后不能否认他发送过数据这一事实,签名验证过程,?,摘要,摘要,摘要,MIC,摘要,MIC,摘要,摘要,公开密钥,秘密密钥,第二部分,网络现状及安全性分析,企业网的现状,ATM,因特网,DDN,X.25帧中继,ISDN,IP 网,PSTN,视频网,VOIP语音网,数据网,VPN网,因特网,WEB 服务器,便携机,企业网互连需求,视频网,VOIP语音网,数据网,VPN网,因特网,WEB 服务器,便携机,快捷,按需,廉价,安全可靠,IP 网,企业网互连的趋势,因特网内部网外部网,商业伙伴/客户,企业总部网,分支机构,路由器,路由器,路由器,远端用户,建立基于公用网的 VPN 虚拟专用网络,Internet 提供快捷,按需,廉价,安全可靠?,公用网络,应用,TCP,IP,UDP,IP 的操作流程,IP 报文,源IP 地址,目的 IP 地址,高层报头,数据,应用,TCP,IP,UDP,10.1.1.1,10.1.1.2,传送IP 报文,X,IP 网潜在安全问题,IP,数据包,IP,数据包,IP,数据包,IP,数据包,IP,数据包,IP,数据包,是谁在网的另一端?,公用IP网络,IP,数据包,X,IP-VPN 网涉及的安全问题,源IP 地址,目的 IP 地址,报文,假IP 地址,假IP 地址,中间人攻击,The man-in-the-middle,诈骗,Spoofing,会话偷换,Session hijacking,电子偷听,Sniffing,这网点是不是真的?,是谁在网的另一端?,你的系统易受攻击吗?,超过 18 个主要操作系统,路由器,打印机等等发现存在TCP/IP 缺陷 Ping of Death.,发送过分大的数据包至使系统超过负荷而崩溃。,IP网络安全问题的根源,我们要保护什么呢?,信息完整,用户认证,网站认证,密钥管理,不可抵赖,数据安全,基于网络层的安全,applications,Presentation,Session,Physical,Transport,Link,S/MIME,SET,Secure RPC,SSL/TLS,-,应用,Presentation,会话,物理,传输,链路,PPP CHAP/EAP L2TP/PPTP,IP SEC,OSI 层的安全,IP SEC,IP SEC,网络,Network,MPLS:多协议标签交换,由IEFT提出,并得到以Cisco为主的网络设备供应商的支持,解决IP网络中数据报的快速交换、和传输质量(QoS),对IP报进行“标签处理”,路由/交换时不再基于IP地址,而是基于该“标签”进行,从而大大提高传输速率,一般由网络服务商提供,并由服务商设定标签路由分组及访问控制,根据标签进行快速路由和交换,普通IP报以普通方式进行路由和交换,PPTP:点到点隧道协议,由微软最先提出,提供PPTP客户机和PPTP服务器之间的加密通信,对PPP协议进行二次封装,采用RSA、RC4密码算法完成身份认证及数据加密,仅在PPTP客户端和PPTP服务器之间提供安全机制,仅同时支持一个PPTP连接,Internet或IP网络,1.拨号,建立PPP连接,PPTP服务器,2.基于RSA进行PPTP认证,3.基于RC4对数据加密,L2TP:二层隧道协议,以网络厂商为主提出,在IP网络或分组网络中直接建立安全的IP连接,基于TACACS+、RADIUS进行身份认证,引入二层传输序列号,防止数据报丢失,仅对控制信息进行加密处理,Internet或IP网络,LNS,FR/ATM等交换网络,PSTN,LNS,L2TP Network Server,IETF(因特网工程工作组)为 IP 网络层制订的安全标准。,强制包含在 IPv6 版本,在IPv4 版本可选择的,互联网安全协议,解决方案,IPSec,RFCs IPSec协议(1998年11月),RFC 2401:Security Architecture for the Internet Protocol,RFC 2402:IP Authentication header(AH),RFC 2403:The Use of HMAC-MD5-96 within ESP and AH,RFC 2404:The Use of HMAC-SHA-1-96 within ESP and AH,RFC 2405:The ESP DES-CBC Cipher Algorithm With Explicit IV,RFC 2406:IP Encapsulating Security Payload(ESP),RFC 2407:The Internet IP Security Domain of Interpretation for ISAKMP,RFC 2408:Internet Security Association and Key Management Protocol(ISAKMP),RFC 2409:The Internet Key Exchange(IKE),RFC 2410:The NULL Encryption Algorithm and Its Use With IPsec,RFC 2411:IP Security Document Roadmap,RFC 2412:The OAKLEY Key Determination Protocol,RFC 2451:The ESP CBC-Mode Cipher Algorithms(3DES,CAST,IDEA,RC5,BF),RFC 2393:IP Payload Compression Protocol(IPComp),RFC 2394:IP Payload Compression Using DEFLATE,RFC 2395:IP Payload Compression Using LZS,RFC 2104:Keyed-Hashing for Message Authentication,在研讨中的 IPSec v2版本草案,draft-ietf-ipsec-pki-req-01:PKI Requirements for IP Security,draft-ietf-ipsec-isakmp-xauth-03:Extended Authentication Within ISAKMP/Oakley,draft-ietf-ipsec-isakmp-hybrid-auth-01:A Hybrid Authentication Mode for IKE,draft-ietf-ipsec-isakmp-mode-cfg-04:The ISAKMP Configuration Method,draft-ietf-ipsec-policy-model-00:IPSec Policy Data Model,draft-ietf-ipsec-vpn-policy-schema-00:An LDAP Schema for Configuration and Administration of IPSec based Virtual Private Networks(VPNs),draft-ietf-ipsec-secconf-00:Secure Configuration of IPsec-Enabled Network Devices,draft-ietf-ipsec-sps-00:Security Policy System,draft-ietf-ipsec-spsl-00:Security Policy Specification Language,draft-jenkins-ipsec-rekeying-00:IPSec Re-keying Issues,draft-ietf-ipsec-mib-02:IPSec Monitoring MIB,draft-ietf-ipsec-icmp-handle-v4-00:IPv4 ICMP messages and IPSec security gateways,draft-ietf-ipsec-icmp-options-00:Options for handling ICMP messages that must be forwarded,draft-ietf-ipsec-auth-hmac-ripemd-160-96-02:The Use of HMAC-RIPEMD-160-96 within ESP and AH,draft-simpson-desx-02:The ESP DES-XEX3-CBC Transform,draft-rogers-cbc-mac-00:Use of Block Ciphers for Message Authentication,draft-ietf-ipsec-dhless-enc-mode-00:A DH-less encryption mode for IKE,传输模式(Transport Mode),应用,TCP,IP,UDP,应用,TCP,IP,UDP,应用,TCP,IP,UDP,AH,IP,应用,TCP,IP,UDP,AH,IP,加密报文,认证报头,原 IP 报头,使用原 IP 地址传送,10.9.2.3,10.1.1.1,公用网络,隧道模式(Tunnel Mode),10.9.2.3,10.1.1.1,应用,TCP,IP,UDP,应用,TCP,IP,UDP,应用,TCP,IP,UDP,AH,IP,应用,TCP,IP,UDP,AH,IP,加密报文,新 IP 报头,认证报头,新 IP 地址:10.1.2.3,使用新 IP 地址传送,公用网络,PAD 长度,下个报头,填充(0-255bytes),IPSec 的主要元素,安全参数索引(SPI),序列号(SN),认证数据,下个报头,报文长度,保留,安全参数索引(SPI),序列号(SN),报文数据,认证数据,AH,使用的散列法,密钥提议,ESP,使用的加密算法,密钥提议,散列法算法,密钥的提议,加密算法,密钥的提议,密钥有效期,SA有效期,SA源地址,密钥更换期,加密算法是否有用同步密码,认证数据,信息源的认证信息的完整性防御报文重发,信息源的认证信息的完整性数据的私密性 防御报文重发,安全协商密钥管理,防御:,不可抵赖,中间人攻击,会话偷换 报文重播,认证报头AH,封装安全报文ESP,互连网密钥交换IKE,AH:认证报头,IP,报头,TCPheader,IP Payload,(incorporates TCP header and data),原始报文,IP,报头,TCPheader,IP Payload,(incorporates TCP header and data),AH,报头,传送模式,认证(IP,AH,Payload),IP,报头,TCPheader,IP Payload,(incorporates TCP header and data),AH 报头,新 IP,报头,隧道模式,认证(新 IP 报头,AH,IP,Payload),RFC 2402IP Authentication Header,ESP:封装安全报文,IP,报头,TCPheader,IP Payload,(incorporates TCP header and data),原始报文,传输模式,IP 报头,TCPheader,IP Payload,(incorporates TCP header and data),ESP 报头,ESP 报尾,ESP 鉴定,加密,认证,隧道模式,IP,报头,TCPheader,IP Payload,(incorporates TCP header and data),ESP 报头,新 IP,报头,ESP 报尾,ESP 鉴定,加密,认证,RFC 2406IP Encapsulation Security Payload,IPSec VPN系统中的两个重要组件,SPD(安全策略数据库),决定了为一个包提供的安全服务,系统安全的灵魂,策略管理(添加、删除、修改)应方便、安全(集中管理),SADB(安全联结数据库),由 IPSec SA组成,具体实施安全服务,IPSec SA(Security Association),决定要保护什么数据包,怎样保护,由谁保护(单向),SADB,SA的创建和删除:手工、自动,在实际运行的VPN系统中,最好采用自动的方法IKE(Internet Key Exchange),IKE协议(RFC2409),目前最完善的、灵活的和健全的自动密钥管理协议,不仅可以为IPSec协商安全联结,还可以用于OSPF、RIPv2。,混合协议:ISAKMP、OAKLEY、SKEME,IKE交换的阶段与交换模式,阶段一交换(IKE SA),阶段二交换(IPSec SA):Quick Mode,Main Mode,Aggressive Mode,IKE SA,消息ID#1,消息ID#2,消息ID#1,消息ID#2,发起者Cookie,响应者Cookie,消息ID,消息长度,下一个载荷,主版本,副版本,交换类型,flag,下一个载荷,保留,载荷长度,ISAKMP消息头,ISAKMP 载荷头,IKE协议提供的安全性,抗拒绝服务攻击:cookie,抗抵赖:签名,安全密钥交换:Diffie-Hellman,抗中间人攻击:对前面的所有消息进行验证,身份认证,身份保护,完美向前保护(PFS),IKE验证方法,PSK,RSA Signature,DSS Signature,Public key authentication,Revised Public Key Authentiation,发起者,响应者,SA,Vendor ID,SA,vendor ID,(icookie,0,0),(发起者cookie,响应者cookie,msgid),(icookie,rcookie,0),HDR,KE,nonce,HDR,KE,nonce,certreq,HDR*,IDii,CERT,SIG_I,HDR*,IDir,CERT,SIG_R,HDR*,散列1,SA,Ni,KE,IDci,IDcr,Icookie,rcookie,xxxx),HDR*,散列2,SA,Nr,KE,IDci,IDcr,HDR*,散列3,阶段一完成,阶段二完成,IKE 协商过程,主模式的三四条消息完成后,双方要计算一系列的秘密:,1、SKEYID:后续所有密钥生成的基础,2、SKEYID_d:用于为IPSec衍生出加密密钥的材料,3、SKEYID_a:用于为IKE消息的完整性和数据源身份的验证,4、SKEYID_e:用于对IKE消息进行加密,对于数字签名:SKEYID=prf(Ni_b|Nr_b,gxy),对于公共密钥加密:,SKEYID=prf(hash(Ni_b|Nr_b),CKY-I|CKY-R),对于共享密钥加密:,SKEYID=prf(pre-shared-key,Ni_b|Nr_b),SKEYID_d=prf(SKEYID,gxy|CKY-I|CKY-R|0),SKEYID_a=prf(SKEYID,SKEYID_d|gxy|CKY-I|CKY-R|1),SKEYID_e=prf(SKEYID,SKEYID_a|gxy|CKY-I|CKY-R|2),IKE的密钥生成,Aggressive Mode,Why need Aggressive mode?,1、当必须使用PSK,而且是远程访问时 2、当发起者知道响应者的策略,速度快,共三条消息:,HDR,SA,KE,Ni,IDii,HDR,SA,KE,Nr,IDir,HASH_R,HDR,HASH_I,为了实现互通,IKE协议规定所有的实现必须支持:,DES-CBC加密算法(事实上,由于single DES的安全性问题,现在基本已被3DES取代),MD5和SHA散列算法,预共享密钥的验证方法,MODP组一(768bit),IKEv2,新的标准将在今年的12月左右确定,主要解决的问题包括:,1、支持 NAT(NAPT)Traversal,2、支持 SCTP,支持新的算法 AES-CBC,AES-MAC,SHA-2,以及一个更适合采用硬件实现的快速模式的AES算法。,IKE MIB 方面的一些标准和文档的制定,对ESP的序列号进行扩展,6.对IKE密钥更新过程进行标准化,IPSec 的操作流程,applications,TCP/UDP,IP,Ethernet/PPP,IPSec,IP,applications,TCP/UDP,IP,Ethernet/PPP,IPSec,IP,选择协议:,AH or ESP,3,公用网络,选择传输或隧道模式,2,1,互联网密钥交换(IKE),安全策略:口令认证法,可在使用证书处使用,IKE 的一部分,用户键入口令建立连接,网关中有下述一张表:,用户,IP 地址,口令,Tech,122.2.3.18,ui9weqmnkkjfhdffu,Sales,100.1.1.11,maryhasalittlelamp,因特网,使用口令建立隧道,使用共享的口令来进行隧道认证,私用IP 地址:11.3.1.1,登录企业网,登录 Internet ISP 分配 IP 地址:9.2.2.2,IP 地址:10.1.1.2,总部局域网,CA 证书和公钥结构(PKI),数字证书/用户,网点,由可信的认证机构(CA)签名,公开密钥和私有密钥,X.509 标准,识别号:,公开密钥:,序列号码,满期,发行者,陈爱国,RSA-512:,451f6c882.8b,2772-18811,2000 年 1 月 30 日,2770-19199,CA 签名,RSA:,177f31cbe94.1f,因特网,使用 CA 证书 建立隧道,使用公开密钥结构进行隧道认证,检验保密口令,输入保密口令或 PKCS11 兼容令牌,总部局域网,安全IPSec-VPN 产品选型,IPSec 标准,线速率/延迟,通信会话,易用性和可管理性,支持CA 证书,冗余备份,中国信息安全产品,测评认证中心,对外办公地点:,北京西三环北路27号,互联网址:,电话:68428899,传真:68462942,展开阅读全文

咨信网声明:本文档由用户上传并分享,仅供学习交流、研究之用,未经授权,严禁复制、发行、汇编、翻译或网络传播等,侵权必究。
咨信网小贴示:
1、浏览或下载可查看了解,请点击【咨信网告知】。
2、下载文件中如有侵权或不适当内容,将立即纠正。
3、如果因为网速或其他原因下载失败请重新下载,重复下载[60天内]不扣币。
4、开具发票登录电脑端申请,请点击【索取发票】。
咨信网客服组:【微信客服】
1、浏览或下载可查看了解,请点击【咨信网告知】。
2、下载文件中如有侵权或不适当内容,将立即纠正。
3、如果因为网速或其他原因下载失败请重新下载,重复下载[60天内]不扣币。
4、开具发票登录电脑端申请,请点击【索取发票】。
咨信网客服组:【微信客服】


加密技术应用.ppt
















自信AI助手














微信客服
客服QQ
发送邮件
意见反馈



链接地址:https://www.zixin.com.cn/doc/14743975.html