第7章VB控件.ppt
- 配套讲稿:
如PPT文件的首页显示word图标,表示该PPT已包含配套word讲稿。双击word图标可打开word文档。
- 特殊限制:
部分文档作品中含有的国旗、国徽等图片,仅作为作品整体效果示例展示,禁止商用。设计者仅对作品中独创性部分享有著作权。
- 关 键 词:
- VB 控件
- 资源描述:
-
单击以编辑母版标题样式a,单击以编辑母版文本样式a,第二级a,第三级,第四级,第五级,*,第7章 VB的窗体及常用控件,数据库编程技术,1,7.2 常用标准控件7.2.1 窗体(Form),1.窗体的常用属性,Name,:名称。按照窗体的添加顺序,默认名依次为Form1,Form2等,可在属性窗口中改变窗体的名称。,该属性值将出现在过程代码中的对象名称部分。,如在窗体中引用Print方法,语句为:,Form1.Print,若窗体改名为,frm,,则该语句为:,frm.Print,StartUpPosition,:启动位置。指明窗体首次显示在屏幕的位置。数值量,0屏幕左上角;1、2屏幕中心;3(默认值)默认位置。,Height:,设置窗体高度。此高度包括标题栏和边框的高度。是数值量,单位:缇(Twip,音ti,15缇=1像素)。当用鼠标调整窗体的高度时,该属性值随之改变。,Width:,设置窗体宽度。,2,Left,:左边距。指明窗体左边线与屏幕左边线之间的距离。数值量,单位:缇。当用鼠标左右移动窗体时,该值随之改变。,Top,:上边距。指明窗体上边线与屏幕上边线之间的距离。,2.窗体的常用事件,Click,:用鼠标单击窗体时触发此事件。,DblClick,:用鼠标双击窗体时触发此事件。,Load,:窗体被装载入内存时,触发此事件。该事件优先于其它事件发生,常用来放变量和属性初始化的代码。,3,Unload:卸载。窗体从内存中卸载时触发此事件。,例:,Unload Me,卸载当前窗体,Unload Form2,卸载Form2窗体,Show:显示窗体。,例:,Form2.Show,显示Form2窗体,Hide:隐藏窗体。,例:,Form2.Hide,4,【例7.2】在一个窗体中,打开另外的窗体。,新建一个工程,用“工程”菜单的“添加窗体”命令添加一个窗体Form2。在属性窗口中将Form1的背景色(BackColor)设为浅红色,将Form2的背景色设为浅绿色。,双击Form1,打开Form1的代码窗口,在Form1的单击事件过程中编写如下代码:,Private Sub Form_Click()Form1的单击事件过程,Form1.Hide 隐藏Form1,Form2.Show 显示Form2,End Sub,5,7.2.3,标签Label,主要用于,显示文本信息.,用Caption属性设置显示的信息.,标签的属性,Name:,名称。默认名称:Label 1,Label 2.。,Caption,:标题。设置显示的文本。默认标题:Label 1,Label 2 等。,例:,用标签显示字符串:“程序设计”,Label1.,Caption,=“程序设计”,St$=Label1.,Caption,Label1,中的字符赋值给变量St,8,AutoSize,:自动缩放.设为True时,根据标题文字的长短,自动调整标签的宽度大小。,Alignment,:设置文本在标签中对齐的方式。0:左对齐;1:右对齐;2:居中。,BorderStyle,:边框样式。0(默认值)无边框,1单边框。,BackStyle,:背景样式。0透明的;1(默认值)不透明的。,标签响应的事件,Click,单击事件。单击标签时触发此事件。,DblClick,双击事件。双击标签时触发此事件。,9,【例7.3】输入一个半径值,计算圆周长、圆面积。,在单击命令钮事件过程中,利用InputBox函数输入半径值,计算出的结果用标签的Caption属性显示出来。,(1)设计界面如图7.1a。,(2)设置属性如表7.1。,图7.1a 例7.3界面设计,对象名称,属性名,属性值,对象名称,属性名,属性值,窗体,Name,Caption,Form1,圆的计算,命令钮,Name,Caption,Command2,结束,命令钮,Name,Caption,Command1,开始,标签,Name,BackColor,Label1,白色,10,(3)编程如下:,单击“开始”命令钮执行的过程代码:,Private Sub Command1_Click(),Dim r As Single,Dim c As Single,Dim a As Single,Const PI#=3.1415926,定义符号常量PI,r=Val(InputBox(“请输入半径值,:”,),c=2*PI*r,a=PI*r2,用标签控件显示计算结果,Chr(10)转换为换行符:,Label 1.Caption=“圆半径=”&Str(r)&“厘米”&Chr(10)_,&“圆周长=”&Str(c)&“厘米”&Chr(10)_,&“圆面积=”&Str(a)&“平方厘米”,End Sub,Private Sub Command2_Click(),单击结束命令钮执行的过程代码,End,End Sub,11,7.2.4 文本框(TextBox),文本框既可以用来输入信息,也可以用来输出信息。,文本框的主要属性,Name,:名称。默认名称:Text1,Text2 等。,Text,:存放文本框内显示的字符串。默认值为Text1,Text2.,例:,在文本框Text1中显示字符串:“程序设计”,Text1.,Text,=“程序设计”,St$=Text1.,Text,Text2中的字符赋值给变量St,12,ForeColor,:设置文本框中显示的字体的颜色.,例:设文本框字体颜色为红色:,Text1.,ForeColor,=vbRed,BackColor,:设置文本框的背景色。,例设文本框背景色为黄色:Text1.,BackColor,=vbYellow,MultiLine,:设置能否存放多行文本。False(默认值):单行;True:多行。,ScrollBars,:设置文本框中的滚动条。0无滚动条;1水平滚动条;2垂直滚动条;3水平、垂直滚动条都有。,13,Passwordchar,:设置密码替换符。若用户在文本框内输入密码,可将Passwordchar设为,*,则无论在文本框中输入什么,都将显示,*,符号。默认值为空.,主要事件和方法,Change,事件:文本框中的内容发生改变时触发此事件,每输入一个字符,触发一次该事件。,SetFocus,方法:可以把输入焦点移到指定的文本框中。,使用格式:文本框名.SetFocus,例:执行以下语句,可让Text1获得焦点:,Text1.,SetFocus,14,例7-4:铁路托运行李,从甲地到乙地,按规定,不超过50kg时,运费为1.3元/kg,如超过50kg,超过部分按2元/kg 计费。,解:用文本框输入重量,用另一个文本框输出结果,确定计算公式:设重量w,运费f,,f=1.3*w (w50kg),设计界面如图。,图7-2 运行界面,15,(2)属性设置如表。,对象名,属性名,属性值,Form1,Caption,计算运费,Label1,Caption,Font,输入行李重量:,小四号,Label2,Caption,Font,应付运费金额,小四号,Text1,Text,空,Text2,Text,空,CmdOk,Caption,确定,CmdCancel,Caption,取消,16,Private Sub CmdOk_Click(),确定,按钮单击事件,Dim f As Single,w As Single,w=Val(Text1.Text),将文本框输入的数据赋给w,If,w 0,Then,Label1.Top=Label1.Top 20,Else,Label1.Top=Form1.ScaleHeight,End If,End Sub,40,Private Sub Command1_Click(),If Command1.Caption=暂停 Then,Timer1.Enabled=False,定时器停止工作,Command1.Caption=继续,改变命令钮的标题,Else,Timer1.Enabled=True,启动定时器,Command1.Caption=暂停,改变命令钮的标题,End If,End Sub,41,7.2.11 图形类控件,1.图片框(PictureBox)和图象框(Image),用于显示图片或图形的.可以显示多种图形格式的图片.,图片框控件(PictureBox),图片框的属性,Name,:名称。默认的图片框的名称为Picture1,Picture2等等。,Picture,:用于存放图片文件的路径及文件名。,AutoSize,:自动缩放。逻辑量,设为,True,时,可以自动改变图片框控件的大小,以适应图片的大小。默认值为False。,AutoRedraw,:自动重画。设为True时,如果窗体被覆盖部分重新露出时,会自动重画,恢复原状.,42,图片框的事件,Click 单击事件。,DblClick 双击事件。,图片框的方法,Print,:用该方法可以在图片框上输出文本。例如:,Picture1.Print“您好!”,使用Print方法的前提条件是AutoRedraw属性值为True。,Cls:,清除图片框上用Print输出的文字。,Move,:移动图片框。,43,7.2.12 图象框(Image),图像框的属性:,Name,:名称。默认名为,Image1,,,Image2,等等。,Picture,:图片。指定图片文件的路径及文件名。,Stretch,:拉伸。调整所装载的图片的大小以适应图像框(Image)控件的大小。,图像框的方法:,Move:移动图像框。,44,3.图形文件的装入,无论是图片框还是图像框控件,为它们装载图像的方法有以下二种:,(1)在属性窗口中设置Picture属性。,(2)在代码中装载:,用LoadPicture()函数为Picture属性赋值。该函数的使用格式是:,LoadPicture(,图像文件名,),例:Picture1.Picture=,LoadPicture(,a:路径名Clouds.bmp,),Image1.Picture=,LoadPicture(,“c:路径名Clouds.bmp”,),45,例7.12 模拟交通信号灯的切换.每隔5秒自动切换,体上安放3个Image控件,分别放不同信号灯图片,大小相同,重叠安放。在Timer()事件中,控制3幅图片轮流显示,即可达到红、黄、绿灯轮流亮的效果。,(1)设计界面如图7.10a,新建一个工程,在窗体上添加三个图像框Image1、Image2、Image3,三者在窗体上重叠安放;,一个定时器Timer1,一个命令钮Cmd1,用于控制定时器的启动/停止。,图7.10a 例7.12设计界面,46,(2)设置属性见表7.10,对象名,属性名,属性值,Image1,Picture,Trffc10a.ico,Image2,Picture,Trffc10b.ico,Image3,Picture,Trffc10c.ico,Timer1,Interval,Enabled,500,False,Cmd1,Caption,启动,47,编程如下:,Private Sub Form_Load(),Image2.Visible=False,Image3.Visible=False,End Sub,Private Sub Timer1_Timer(),If Image1.Visible=True Then,Image1.Visible=False,Image2.Visible=True,ElseIf Image2.Visible=True Then,Image2.Visible=False,Image3.Visible=True,Else,Image3.Visible=False,Image1.Visible=True,End If,End Sub,48,Private Sub Cmd1_Click(),If,Cmd1,.Caption=“停止”Then,Timer1.Enabled=False,定时器停止工作,Cmd1,.Caption=“启动”,修改按钮的标题为“启动”,Else,Timer1.Enabled=True,定时器开始工作,Cmd1,.Caption=“停止”,修改按钮的标题为“停止”,End If,End Sub,49,7.3 用户自选控件(ActiveX),用户自选控件平时不出现在工具箱中,要想使用这些控件,需要将它们添加到工具箱中,然后像使用标准控件一样使用它们。,50,7.5 菜单设计,7.5.1菜单编辑器,在VB中,利用“菜单编辑器”建立菜单。启动菜单编辑器的方法:单击“工具”菜单的“菜单编辑器”项,,图8-1 VB6.0菜单编辑器,51,7.5.2 建立菜单的步骤,例.在Form1中建立菜单结构,如图,文件(,F,)帮助(,H,),关于,打开,关闭,退出,文件的下级子菜单,分组线,主菜单,1 设计菜单的结构,2 设置菜单的属性,为了清楚,将各菜单项的属性列表,选“,工具,”菜单的“,菜单编辑器,”项,在打开的菜单编辑器窗口中,编辑菜单控件的各属性。,3 为各菜单控件编写过程代码,52,2 属性列表如下:,标题和位置 名称 快捷键,文件(&F),fmenu,.打开 f_open Ctrl+O,.关闭 f_close,.f_line1,.,退出 f_exit F4,帮助(&H)hmenu,.关于 h_about F1,例7.17,1 设计菜单结构:,文件(,F,)帮助(,H,),关于,主菜单,打开,关闭,退出,文件的下级子菜单,分组线,53,3 在菜单编辑器中,输入以上各属性。,4 为各菜单控件编写代码,为“打开”菜单编写代码:,Private Sub f_open_Click(),Load Form2,Form2.show,End Sub,为“关闭”菜单编写代码:,Private Sub f_close_Click(),Unload Form2,End Sub,为“退出”菜单编写代码:,Private Sub f_exit_Click(),End,End Sub,54,在工程中添加一个新窗体,Form2,在Form2中添加一个命令钮控件,设Caption属性为“返回”,双击该命令钮,编写代码如下:,Private Sub Command1_Click(),Form1.Show,显示Form1,End Sub,55,7.5.3 创建快捷菜单,建立快捷菜单的方法:用PopupMenu方法。,语法格式:,对象名.PopupMenu 菜单名,位置参数,说明:,位置参数,:指定鼠标指针在快捷菜单的左边还是右边或中间。这是个数值量,也可以用VB内部常量表示,其取值含义如下:,0(vbPopupMenuLeftAlign)鼠标指针在弹出快捷菜单的左边界,4(vbPopupMenuCenterAlign)鼠标指针在弹出快捷菜单的中间,8(vbPopupMenuRightAlign)鼠标指针在弹出快捷菜单的右边界,56,例如在上例中,要实现:单击鼠标右键弹出文件菜单中的内容,且鼠标指针在弹出快捷菜单的右边界。,编程如下:,Private Sub Form_MouseDown(Button As Integer,Shift As Integer,X As Single,Y As Single),If Button=2 Then,PopupMenu,fmenu,8,或:PopupMenu,fmenu,vbPopupMenuRightAlign,End If,End Sub,57,这里MouseDown()是按下鼠标时发生的事件。,其中参数 Button=1 表示按下了鼠标左键,Button=2 表示按下了鼠标右键,所以上面的程序实现:如果按下鼠标右键,则弹出菜单,且鼠标指针位于快捷菜单的右边界位置。,58,第7章 结束,59,展开阅读全文

咨信网声明:本文档由用户上传并分享,仅供学习交流、研究之用,未经授权,严禁复制、发行、汇编、翻译或网络传播等,侵权必究。
咨信网小贴示:
1、浏览或下载可查看了解,请点击【咨信网告知】。
2、下载文件中如有侵权或不适当内容,将立即纠正。
3、如果因为网速或其他原因下载失败请重新下载,重复下载[60天内]不扣币。
4、开具发票登录电脑端申请,请点击【索取发票】。
咨信网客服组:【微信客服】
1、浏览或下载可查看了解,请点击【咨信网告知】。
2、下载文件中如有侵权或不适当内容,将立即纠正。
3、如果因为网速或其他原因下载失败请重新下载,重复下载[60天内]不扣币。
4、开具发票登录电脑端申请,请点击【索取发票】。
咨信网客服组:【微信客服】


第7章VB控件.ppt
















自信AI助手














微信客服
客服QQ
发送邮件
意见反馈



链接地址:https://www.zixin.com.cn/doc/14655069.html