分享
分销 收藏 举报 申诉 / 23

类型报表设计.ppt

  • 上传人:仙人****88
  • 文档编号:14036741
  • 上传时间:2026-06-11
  • 格式:PPT
  • 页数:23
  • 大小:145KB
  • 下载积分:10 金币
  • 配套讲稿:

    如PPT文件的首页显示word图标,表示该PPT已包含配套word讲稿。双击word图标可打开word文档。

    特殊限制:

    部分文档作品中含有的国旗、国徽等图片,仅作为作品整体效果示例展示,禁止商用。设计者仅对作品中独创性部分享有著作权。

    关 键  词:
    报表 设计
    资源描述:
    第9章 报表设计,第九章 报表,设计,1,9.1,报表和标签设计技术,9.2,利用向导创建报表,9.3,使用报表设计器,9.3,使用报表,9.5,标签文件的建立,2,9.1 报表和标签设计技术,9.1.1 报表的数据源和布局,报表是各种数据最常用的输出形式。通过设计报表,可以用各种方式在打印页面上显示数据。,标签是一种特殊的报表。,VFP,报表包括两个基本部分:,数据源,和,布局,。,数据源:,数据库中的表、视图、查询或临时表,还可以是某些数据,的运算结果。,报表主要就是用来显示数据源中的内容。,布局:,定义报表中各显示内容的位置和格式。,在,VFP,中设计报表主要便是设计报表布局,并将布局保存到报表文件中。,9.1.2 报表的常规布局,列布局:,一行一条记录,每条记录的所有字段在页面上按水平方向放,置。,行布局,:,一行一个字段,字段垂直排放成一列。如:电话号码簿。,一对多布局:,显示一对多关系的数据。如:学生成绩通知单。,多列布局:,每条记录的所有字段垂直排放在一列,但一个页面上有多,列记录。,标签布局:,与多列报表类似,每个记录的所有字段垂直排放在一列,,一个页面上有多列记录,但打印在特殊纸上。,9.1.3 创建报表的方法,创建报表文件方法有3种:,(1)利用报表向导;,(2)利用报表设计器;,(3)利用快速报表方法创建。,报表文件的文件扩展名为,.,FRX,,,它存储报表的详细说明。每个报表文件还有一个扩展名为,.,FRT,的相关(备注)文件。,9.2 利用向导建报表,9.2.1 主要步骤,1、在“向导选取”窗口选取报表向导类型;,2、确定数据来源(表、视图或查询);,3、确定报表样式;,4、确定报表中数据的排列顺序;,5、预览报表或打印报表。,9.2.2 示例,例9.1,利用报表向导创建报表文件“学生专长情况表”,报表的数据源为表“,expert”。,操作步骤:,1、打开“向导选取”;,2、选取“报表向导”;,3、字段选取;,4、选择报表分组记录;,5、选择报表样式;,6、定义报表布局;,7、确定报表中的数据输出顺序;,8、先确定存储方式为“保存报表以备将来使用”,然后按“完成”按钮,进入“另存为”窗口;,9、在“另存为窗口”输入新建的报表名字“专业情况报表”,然后按“保存”按钮,即可。,例9.2,用“学生”和“成绩”二个表建一个一对多报表。,9.3 利用报表设计器创建报表,9.3.1,设置报表页面与布局,设置报表的页面与布局需要在“报表设计器”窗口进行。,第1步:,选择“文件”菜单新建报表 新建文件,进入“报表设计器”窗口,。,第2步:,在“报表设计器”窗口,打开“文件”“页面设置”,进入“页面设置”窗口,。,第3步:,在“页面设置”窗口,可以,设置报表页面的大小、布局,。,9.3.2,报表设计器的带区,报表带区:,是指报表中一块带状的区域。打开报表设计器后,即可看到各种不同类型的带区,每个带区中都可以放置一些报表控件,如表的字段、计算值、说明文字、函数、线条、边框和图片等。,3个基本带区:页标头、细节、页注脚。最多可有9个带区。,报表各带区情况说明,标题/总结:,在报表开始/结束处打印一次。,创建:从“报表”菜单中选择“标题/总结”,页标头/页注脚:,在每页开始/结束处打印一次。,创建:默认可用,细节:,每条记录打印一次。,创建:默认可用,组标头/组注脚:,每组开始/结束处打印一次。,创建:“报表”“数据分组”,列标头/列注脚:,每列开始/结束处打印一次,创建:“文件”“页面设置”,设置“列数”1,9.3.3,数据环境设计器,1.设置数据源:,打开“数据环境设计器”,添加表或视图。,2.设置属性:,当数据源设置好后,我们可规定记录出现在报表中的顺序,其方法是为数据环境设置索引。,如果创建的是一对多报表,在“属性”窗口中设置“,Relation1,”,的,OneToMany,属性为“真”。既设置所建报表为一对多报表。,设置“,Cursor1,”,的,Order,属性为父表的排序索引。,设置“,Cursor2,”,的,Order,属性为子表的排序依据。,9.3.4,报表控件,在“报表设计器”窗口,对于数据的输出控制,是通过报表控件属性控制输出操作。这些控件的属性决定了数据的输出格式、大小、颜色及位置等。,9.3.5,设计报表,例9.3利用报表设计器创建报表文件“学生情况报表”,报表的数据来源为表“,student”。,操作步骤如下:,1、打开报表设计器;,2、在“报表设计器”窗口,打开“显示”菜单,选择“数据环境”;,3、在“数据环境设计器”窗口,打开“数据环境”菜单,选择“添加”选项,添加,student,表;,4、退出“数据环境设计器”窗口;,5、在,Visual FoxPro,系统主菜单下,打开“报表”菜单,选择“,快速报表,”;,6、在“快速报表”窗口,单击“字段”按钮,进入“字段选择器”窗口,添加字段,“确定”并返回“快速报表”窗口;,7、在“报表设计器”窗口,打开“显示”菜单,选择“预览”;,8、保存报表“学生情况报表.,frx,”,即可。,9.3.6,修改报表,一、报表分组,设计报表的布局时,可以根据一定的条件对记录分组,这样可以使报表更易于阅读。,可以添加一个或多个分组依据,分组之后,报表布局就有了组标头和组注脚带区,可以向其中添加控件。,一般地,把分组所用的域控件从“细节”带区移动到“组标头”带区;把组标题从“页标头”带区移动到“组标头”带区中,组注脚通常包含组总计和其它组总结性信息。,二、定义页面标头和注脚,设置在“页标头”和“页注脚”带区内的控件,将在报表的每个页面出现一次。有很多页的报表应在页标头或页注脚中包含报表名称、页码、日期和标签。,例如:把标签“学生情况表”添加到页标头带区,这样每一页的开始处都会出现页标题“学生情况表”这几个字。,三、修改控件,控件的选择、移动、缩放、复制、删除、定位和对齐等操作和在“表单设计器”中的操作是一样的。,注意:标签控件的大小由文本、字体及磅值决定。,四、设置控件中文本的字体和对齐方式,1设置控件中文本的字体:,在“格式”菜单中选择“字体”。,2设置控件中文本的对齐方式:,在“格式”菜单中选择“文本对齐方式”。,五、设置域控件的输出格式,(1)在域控件上右击,在快捷菜单中单击“属性”选项,或双击该控件。,(2)在“报表表达式”对话框中,单击“格式”文本框后面的“”按钮。,(3)在“格式”对话框中,选择域控件的数据类型。,(4)从“编辑选项”区域中选择格式选项。,六、添加线条、矩形和圆,在报表中添加一些线条、矩形和圆等控件可以增加报表布局的视觉效果。选择线条或矩形后,在“,格式,”菜单下的,“,绘图笔,”,子菜单中可以选择线条的类型和宽度。,七、添加通用字段或图片,可以在报表中插入包含,OLE,对象的通用型字段。,(1)从“报表控件工具栏”中,单击“图片/,ActiveX,绑定控件”按钮。,(2)在“报表设计器”中相应的带区拖出一个方框。,(3)在弹出的“,报表图片,”对话框中的设置“图片来源”。,八、修改控件颜色,可以更改域控件、标签、线条和矩形的颜色。,(1)选择要修改颜色的控件。,(2)在“,调色板,”工具栏中选择“前景色”或“背景色”。,(3)选定希望的颜色。,9.4 使用报表,9.4.1,菜单方式使用,步骤如下:,(1)在,VFP,系统主菜单下,打开“文件”菜单,选择“打开”选项,进入“报表设计器”窗口;,(2)在“报表设计器”窗口,打开“文件”菜单,选择“打印预览”选项,可以预览报表;,(3)在“报表设计器”窗口中,打开“文件”菜单,选择“打印”选项,可以通过打印机打印报表的内容。,9.4.2,命令格式,格式1:,Modify Report,功能:在“报表设计器”窗口中,打开以为名的报表。,格式2:,Report form,prev,功能:预览以,为名的报表。,格式3:,Report form,to printer,功能:在打印机上输出,为名的报表。,9.5 标签文件的建立,标签,是一种特殊的报表。,一个标签一般,只包含关于一个记录的信息,。,标签的创建、修改方法与报表基本相同。和创建报表一样,我们可以使用“,标签向导,”创建标签,也可以直接使用“,标签设计器,”创建标签。无论使用哪种方法来创建标签,均必须指明使用的标签类型,它确定了标签设计器中“细节”的尺寸。,9.5.1利用向导建标签,(1)在项目管理器中选择“标签”选项,单击“新建”按钮。,(2)在“新建标签”对话框选择“标签向导”按钮。,(3)在“标签向导”的“步骤1-选择表”中选择要使用的表。,(4)在“步骤2-选择标签类型”对话框中选择标签类型。,(5)在“步骤3-定义布局”对话框中,选择在标签中使用的字段及各字段间的分隔符(分隔符可以使用“.”、“,”、“-”、“:”、空格或换行)。,(6)在“步骤4-排序记录”对话框中选择排序字段。,(7)选择“预览”按钮,将会看到标签预览效果。,(8)保存标签到指定位置。,9.5.2标签设计器,(1)在项目管理器中选定“标签”选项卡,单击“新建”按钮。,(2)单击“新建标签”按钮,弹出“新建标签”对话框。,(3)在“新建标签”对话框中选择,标签布局,,然后选择“确定”按钮。,“标签设计器”与“报表设计器”相似,其使用方法大同小异,可以参照报表文件的设计和修改方法进行操作。,
    展开阅读全文

    开通VIP折扣优惠下载文档

    提示  咨信网声明:本文档由用户上传并分享,仅供学习交流、研究之用,未经授权,严禁复制、发行、汇编、翻译或网络传播等,侵权必究。

    咨信网小贴示:
    1、浏览或下载可查看了解,请点击【咨信网告知】。
    2、下载文件中如有侵权或不适当内容,将立即纠正。
    3、如果因为网速或其他原因下载失败请重新下载,重复下载[60天内]不扣币。
    4、开具发票登录电脑端申请,请点击【索取发票】。

    咨信网客服组:【微信客服】

    自信AI创作助手
    关于本文
    本文标题:报表设计.ppt
    链接地址:https://www.zixin.com.cn/doc/14036741.html

    Copyright ©2010-2026   All Rights Reserved  宁波自信网络信息技术有限公司 版权所有   |  客服电话:0574-28810668    微信客服:咨信网客服    投诉电话:18658249818   

    违法和不良信息举报邮箱:help@zixin.com.cn    文档合作和网站合作邮箱:fuwu@zixin.com.cn    意见反馈和侵权处理邮箱:1219186828@qq.com   | 证照中心

    12321jubao.png12321网络举报中心 电话:010-12321  jubao.png中国互联网举报中心 电话:12377   gongan.png浙公网安备33021202000488号  icp.png浙ICP备2021020529号-1 浙B2-20240490   


    关注我们 :微信公众号  抖音  微博  LOFTER               

    自信网络  |  ZixinNetwork