分享
分销 收藏 举报 申诉 / 76

类型spss-应用简介.ppt

  • 上传人:快乐****生活
  • 文档编号:14665678
  • 上传时间:2026-10-27
  • 格式:PPT
  • 页数:76
  • 大小:2.90MB
  • 下载积分:10 金币
  • 配套讲稿:

    如PPT文件的首页显示word图标,表示该PPT已包含配套word讲稿。双击word图标可打开word文档。

    特殊限制:

    部分文档作品中含有的国旗、国徽等图片,仅作为作品整体效果示例展示,禁止商用。设计者仅对作品中独创性部分享有著作权。

    关 键  词:
    spss 应用 简介
    资源描述:
    单击此处编辑母版标题样式,单击此处编辑母版文本样式,第二级,第三级,第四级,第五级,*,单击此处编辑母版标题样式,单击此处编辑母版文本样式,第二级,第三级,第四级,第五级,*,SPSS for Windows,SPSS,软件是由美国,SPSSStatistical Package for Social Sciences,,即“社会科学统计软件包”。该软件是国际上公认的最优秀的统计分析软件包之一。它在经济、工业、管理、心理、教育、医学等许多领域应用广泛,在科研工作中发挥了巨大的作用。,SPSS,最初的版本是建立在,D0S,基础上的,但在,80Microsoft,推出,WindowsSPSS,迅速向,Windows,移植。并不断推出,SPSS,软件的新版本。,SPSS for Windows,版本从,6.0,、,7.0,、,8.0,、,9.0,、,10.0,、,11.0,、,12.0,、,13.0,、,14.0,至,2006,年底,正式推出,SPSS15.0 for Windows,版本。该版本相对于一些早期的版本而言,不仅改写了一些模块,使运行速度大大提高,而且根据统计理论与技术的发展,增加了许多新的统计分析方法,使之功能日趋完善。目前最新版本是,21.0,,于,2012,年,9,月推出。,Windows17.0,后为多语言版本,有简体中文版。,SPSS for Windows,的特点,SPSS,软件风靡世界并为各个领域的广大科研工作者及其他用户所钟爱,原因在于它有以下的特点;,1,、多种实用分析力法。,SPSS,提供了多种分析方法,包括了从基本的统计特征描述到诸如非参数检验、生存分析等各种高层次的分析。除此之外,,SPSS,还具有强大的绘制图形、编辑图形的能力。,2,、易于学习,易于使用。对于,SPSS for Windows,而言,除了数据输入工作要使用键盘之外,其他的大部分操作均可以通过“菜单”、“对话框”来完成,使用户不必记忆大量的命令,操作更简单。,3,、文件易于转换。与其他软件有数据转换接口。,Excel,文件、,Access,、,Lotues,、,Foxbase,、,Foxpro,、文本数据文件等均可以转换成相应的,SPSS,数据文件。,4,、操作方法多种多样。不仅有灵活的菜单对话框式操作,而且用户也可以自已编写,SPSS,语句来进行数据统计分析工作。,SPSS for Windows,对计算机环境的要求,一、对硬件的要求,由于,SPSS,主要用途是面向大型数据库的,它的运算一般涉及的数据量比较多。故而用户一般需要有较大的内存,而且如果用户还要进行多因素分析、生存分析之类的大运算量的分析,计算机至少要有,16M,的内存。,数据文件的建立、调用、编辑与整理,数据文件的建立与保存,一、数据管理窗口的简介,和大多数应用软件相同,,SPSS,中数据文件的建立、调用、编辑与整理功能的菜单组织结构和,WORD,等也极为相似,因此这里我们只介绍比较有特色的几个菜单项。,SPSS,有三个主要窗口界面:,数据管理窗口、程序编辑窗口和结果浏览窗口。,他们共享许多菜单项,这里介绍的许多内容在三个窗口中都是通用的。本章只介绍数据管理窗口。,SPSS,启动后首先出现如图,21,所示的对话柜,提示用户选择下一步将要执行的任务:进入向导,(Run the tutorial),、新建数据,(Type in Data),、打开已存在的各种数据文件等。在此选择“,Type in data”,,击“,OK”,,进入,SPSS,程序主界面。,上图所示为,SPSS,启动后在屏幕上显示的数据管理窗口。屏幕第一行为标题拦。它显示的是目前数据文件的文件名。由于数据管理窗口还没有数据文件存在,因此系统指定一个默认的文件名:,Untitled,。屏幕第二行为程序主菜单。它包括以下十个菜单项:,1.File(,文件操作,)2.Edit(,文件编辑,)3.View(,视图,)4.Data(,数据文件建立与编辑,)5.Transform(,数据转换,)6.Statistics(,统计分析,)7.Graphs(,统计图表的建立与编辑,)8.Utilities,实用程序,9.Windows(,窗口控制,)10.Help(,帮助,),用,SPSS,软件统计分析的过程,题意分析:确定分析方法,建立数据文件,选择统计方法,进行统计分析,结果浏览和分析,在,SPSS,环境下,数据文件的建立,1,、定义数据结构,2,、输入数据,3,、对数据加工整理,例,1,某克山病区测得,11,例克山病患者与,13,名健康人的血磷值,(mmol/L),如下,问该地急性克山病患者与健康人的血磷值是否不同?,患者,:0.84 1.05 1.20 1.20 1.39 1.53 1.67 1.80 1.87 2.07 2.11,健康人,:0.54 0.64 0.64 0.75 0.76 0.81 1.16 1.20 1.34 1.35 1.48 1.56 1.87,1,、定义变量名,(Name),为变量命名时,单击操作界面“,Variable View”,后,直接在,Name,栏的单元格中输入变量的名称即可。,变量名一般用简单字母后加数字表示,如,X1,、,X2,、,X3,等等。,为更好识别变量,对变量做标签。,注意:不提倡用中文做变量名,本例设立两个变量,组别变量,group,;血磷值,X,。在,Name,栏的单元格中分别输入变量的名称:,group,和,X,,见图,2-3,。,2,、定义变量类型(,Type,),定义变量类型就是指定每个变量的数据类型。,SPSS,变量有三种数据类型:数值型、字符型、日期型。数值型变量按不同要求又可细分为五种,因此一共可定义八种数据类型。系统默认的数据类型为标准数值型,(Numeric),,一个变量若没有定义数据类型,则系统自动赋予该变量以系统默认数据类型,标准数值型,(Numeric),。,定义变量类型的方法:单击操作界面“,Variable View”,后,在用鼠标单击栏中的单元格,(,或移动光标至单元格,),;单元格被选中,单元格内出现按钮框,鼠标点击单,击,框右半部的省略号,弹出下面的对话柜,(,如图,2-4,所示,),。本例选择,Numeric,。,3,、定义变量的,width(,变量长度,),和,Decimals(,小数位数,),变量的长度是指变量值的取值长度,系统默认为,8,。修改此默认值时,点击,width,单元格,出现按钮框,每按一次 则加,1,,按 一次,减少,1,;或者直接从键盘输入修改值。,小数位数对于数值型变量而言是指小数点后的位数,系统默认为,2,,位数超过,2,的系统自动四舍五入。修改此默认值时,点击,Decimals,单元格,出现按钮框,每按,一次则加,1,,按 一次,减少,1,;或者直接从键盘输入修改值。,本例定义宽度为,4,,小数位数,2,位(因小数点还要占一位,故整数位只有一位)。,上部的两个文本框分别为变量值输入框和变量值标签输入框,分别在其中输入“,1”,和“克山病患者”,此时下方的,Add,钮变黑,单击它,该变量值标签就会被加入下方的标签框内。与此类似定义变量值“,2”,为“健康人”,最后按,OK,,变量值标签就设置完成。此时你做任何分析,在结果中都有相应的标签出现。,6,、定义变量的缺失值(,Missing,),缺失值是指在收集数据过程中的无记录或失真数据。对于无记录数据,,SPSS,默认为系统缺失值,(System-Missing),;如果是数值型变量的其值为零,在单元格中显示一个圆点。,对于失真的数据,用户可将其定义为缺失值,以便在统计分析时排除。定义的方法:,7,、定义变量的,Columns(,列宽,),、,Align(,对齐方式,),、,Measure(,度量标准,),变量列宽是指此变量在,Date View,界面中显示的宽度,系统默认等于,8,。但有时为了显示的需要,可能要加大或缩小显示的宽度,方法是,:,点击,Columns,单元格,出现按钮框,每按一次则加,1,,按 一次,减少,1,;或者直接从键盘输入修改值;或者,Date View,在界面有鼠标拖动变量列之间的分割线。,对齐方式,(Align),指变量值显示时的左对齐,(Left),、右对齐,(Right),、居中对齐,(Center),方式。系统默认数值型变量的对齐方式,Right,,而字符型变量的对齐方式是,Left,。,变量的度量标准,(Measure),分为三类:,Scale-,定量变量,如年龄、体重、身高等;,Ordinal-,等级变量,如疗效:治愈、有效、无效、死亡;,Nominal-,定性变量,如血型:,A,型、,B,型、,AB,型、,O,型,对于,Columns,、,Align,、,Measure,,可采用系统默认值。,三、数据文件的保存,需要保存数据文件时,如果文件是新建的,单击菜单,File=Save,或,Save as,,就会弹出对话框;如果数据文件曾经存储过,则系统会自动按原文件名保存数据。单击菜单,File=Save,,将文件存在原位置;单击菜单,File=Save as,,会弹出对话框,将文件存在一个新位置,新建文件还需命名文件名。,SPSS,数据主要可存为三种格式:*,.sav,:保存为,SPSS,数据文件,系统默认格式;*,.xls,:保存,Excel,可以读取的表格数据文件;*,.dbf,:保存为数据库格式文件。,SPSS,数据保存为,SPSS,数据格式以外的其他类型,要注意有些设置可能会丢失,如标签和缺失值等。尤其是缺失值,如果想存的数据格式不支持缺失值,那你的数据可能会变的面目全非。,SPSS,数据文件的调用(打开),SPSS,除了,SPSS,格式文件外,还打开其他多种格式的数据文件。,SPSS10.0 for Windows,现在可以直接读入以下格式的数据文件,其中包括,EXCEL,各个版本的数据文件。,选择菜单,File=Open=Data,或直接单击快捷工具栏上的“”按钮,系统就会弹出,Open File,对话框,单击“文件类型”列表框,在里面能看到直接打开的数据文件格式,分别是:,SPSS(*.sav),SPSS,数据文件(,6.0,10.0,版),SPSS/PC+(*.sys),SPSS 4.0,版数据文件,Systat(*.syd),*.syd,格式的,Systat,数据文件,Systat(*.sys),*.sys,格式的,Systat,数据文件,SPSS portable(*.por),SPSS,便携格式的数据文件,EXCEL(*.xls),EXCEL,数据文件(从,5.0,版,2000,版),Lotus(*.w*),Lotus,数据文件,SYLK(*.slk),SYLK,数据文件,dBase(*.dbf),dBase,系列数据文件,(从,dBase II,IV,),Text(*.txt),纯文本格式的数据文件,data(*.dat),纯文本格式的数据文件,分别收集,12,名高血压病人和,9,名冠心病人的性别、年龄,测量其,CH,、,TG,,结果如下:,练习:,高血压组,冠心病组,性别,年龄,CH,TG,性别,年龄,CH,TG,男,76,5.08,2.46,女,75,5.46,2.00,女,51,3.83,3.37,女,66,5.99,1.15,男,82,4.62,.68,女,57,4.37,1.07,男,76,3.70,.63,男,86,3.84,.83,女,60,6.23,1.89,男,85,4.10,1.64,女,61,4.04,1.42,男,45,5.49,2.52,女,56,8.26,.89,女,45,4.99,2.65,男,63,5.22,2.00,男,80,5.69,.94,男,47,2.85,1.09,男,64,3.79,1.68,男,84,3.25,.76,男,68,4.95,2.35,女,62,3.60,1.67,1,、将此数据用,SPSS,建立数据库文件;,2,、按,group,拆分文件;,3,、选择高血压组病人;选择女性病人;选择年龄在,45,岁,65,岁病人;选择男性冠心病人。,将,Excel,文件转为,SPSS,数据文件方法:,方法一:,1,、在,SPSS,数据编辑窗口点击打开文件按钮;,2,、选择打开的文件类型和要打开的文件;,3,、点击对话框的,Open;,4,、在弹出的“,Opening Excel data source”,对话框,选择数据所在的工作表,点击“,Continue”.,将,Excel,文件转为,SPSS,数据文件方法:,方法二:,1,、在,SPSS,数据编辑窗口打开文件菜单(,File,);,2,、选择,Open database,选择,New Query,;,3,、选择打开的数据文件类型(选择,Excel,文件),;,4,、点击,Next,选择要打开的,Excel,数据文件,点击,Ok,点击,OK,选择变量,数据的编辑与整理,菜单中的“,Edit”,栏的功能和操作方法与,Word,等应用软件相同,在此不作介绍。本节介绍菜单中“,Data”,栏的主要功能和操作方法。在许多情况下,我们需要先对数据进行一些整理(如分组、合并、加权等)才能将其用于最终的统计分析。这些功能基本上都集中在,Data,菜单项中,下面我们就对这些对话框做逐一介绍。,一、数据排序(,Sort Cases,),对例,2.1,数据集按,group,升序,,x,降序的次序排列。操作步骤:,选择菜单,Data=Sort Cases,,系统弹出,Sort Cases,对话框。,这是一个非常典型的,SPSS,对话框。它包含了许多具有,SPSS,特色的对话框元素:对话框左侧为候选变量列表框,里面列出了可被该对话框使用的变量;右上方为,Test Variables,框,可将变量选入其中;注意在两个框的中间用“”相连,这是变量移动按钮,其方向表明是将变量从那个框移动到哪个框,下图中我们选中了变量,group,,移动按钮变黑并向右指,表明变量,group,可以移动到他们右侧的两个框里去,改变当前框(在其他框里单击),移动按钮就会转向、变灰等以表明不同的意思。右侧为一排五个按钮,分别是确定、粘贴、重置、取消和帮助。这五个按钮也是几乎永远一起出现的,另外四个按钮大家都比较熟悉了,重置(,Reset,)按钮用于取消对话框内已做的选择,恢复到默认的状态。,OK,、,Paste,两个按钮为灰色,表明所需条件尚未满足,该按钮暂不可用。,下方的,Sort Order,单选钮,有升序和降序两种选择。请注意,该单选钮是和上方的,Sort By,框一起使用的,具体方法如下:,将,Group,选入,Sort By,框;并选择升序单选钮,Ascending(,系统默认,),将,x,选入,Sort By,框。并选择降序单选钮(,Descending,),击,OK,请注意:,group,和,x,后面分别跟着,Ascending,和,Descending,,表明前者是按升序、后者按降序,排列;由于,Group,在前,因此排序时以,Group,优先。,二、合并文件(,Merge Files,),用于合并数据文件,包括了两个对话框,分别对应两种合并方式:,1.,从外部数据文件中增加记录到当前数据文件中,称为纵向合并,用,Add Cases,对话框完成,相互合并的数据文件中应该有相同的变量。操作步骤,(,1,)选择菜单,Data=Merge Add Cases,,系统首先弹出打开数据文件对话框,选中需要添加的数据文件并按,OK,,,(,2,)系统弹出,Add Cases,对话框,左侧显示的是新、老数据文件中不匹配的变量名,右侧显示的是已经匹配的变量名。可以用,Rename,按钮对不匹配变量改名(先选中)或用鼠标强行匹配(即先按,Ctrl,键选中匹配的两个变量再单击,Pair,钮)。右下方的,Indicate case source as variable,复选框用于定义一个新变量以区分哪些记录是后来添加的。选择停当后单击,OK,,该操作就完成了。,2.,从外部数据文件增加变量到当前数据文件,称为横向合并,用,Add Variable,对话框完成,相互合并的数据文件中应包含同样的记录。操作步骤:,(,1,)选择菜单,Data=Merge Add Variable,对话框,系统同样先弹出打开数据文件对话框(同上),单击,OK,(,2,)弹出和前面相似的,Add Variable,对话框。按需选择即可。,三、拆分文件(,Split File,),用于将数据文件分组进行处理,如对血磷值按分组变量进行计算。操作步骤:,1,、选择菜单,Data=Split Files,系统首先弹出,Split File,对话框。,各个对话框元素的用途,Analyze all cases,单选框:,和下面的两个单选框为一组,选中本框不拆分文件;,Compare groups,单选框:,按所选变量拆分文件,各组分析结果紧挨在一起便于相互比较;,Organize output by groups,单选框:,按所选变量拆分文件,各组分析结果单独放置;,Groups based on,框:,用于选择拆分数据文件的变量;,Sort the grouping variables,单选框:,将数据按拆分变量排序;,already sorted,单选框:,数据保持原状,不按所用的拆分变量排序。,2,、选择,Organize output by groups,单选框或,Compare groups,单选框,3,、把左侧分组变量放置在,Groups based on,框中,4,、点击,OK,注意:如果定义了文件分割,则它会在以后的所有统计分析中起作用,直到你重新定义文件分割方式为止。,四、选择观察单位(,Select Cases,),很多时候我们不需要分析全部的数据,而是按某种要求分析其中的一部分(比如只分析男性的身高、或只对前,200,个数据进行分析以了解大概情况等),这时使用,Select Cases,对话框可以大大简化工作。,按条件筛选,随机抽样,1,、,All cases,单选钮:和下面的,4,个单选钮为一组,选中它则分析所有的记录;,2,、,If condition is satisfied,单选钮:只分析满足条件的记录;,3,、,If,按钮:和,If,单选钮一起使用,单击后弹出,If,对话框;,4,、,Random sample of cases,单选钮:从原数据中按某种条件抽样;,5,、,Sample,按钮:和,Random,单选钮一起使用,可以设定按百分比抽取记录,或者精确设定从前若干个记录中抽取多少个记录;,6,、,Based on time or case range,单选钮:基于记录序号来选择记录;,7,、,Range,按钮:和,Based,单选钮一起使用,用于输入记录序号范围;,8,、,Use filter variable,单选钮:使用筛选指示变量来选择记录,必需在下面选入一个筛选指示变量,该变量取值为非,0,的记录将被选中,进入以后的分析;,9,、,Filtered,单选钮:和下面的,Deleted,单选钮为一组,表示未被选中的记录只是被隔离,这些记录的记录号会被加上斜杠以示区别;,10,、,Deleted,单选钮:未被选中的记录将被删除,一般不要使用。,当对数据集做出筛选后,所做的筛选将在以后的分析中一直有效,直到再次改变选择条件为止,。同时在多数情况下,系统会自动产生一个名为,filter_$,的筛选指示变量,被选中的记录该变量取值为,1,,反之则为,0,。,五、变量加权(,Weight Cases,),在默认情况下,每一行就是一条记录,这在多数情况下没有什么问题,但有时却非常麻烦,想想看如果你需要计算一个四格表卡方,有,100,例,如果每一行就是一条记录,你就需要输入,100,条记录!如果所建立的数据文件有频数变量,就需要用到,Weight Cases,对话框进行加权处理。,按频数,F,对记录进行加权,数据转换(,Transform),当数据集已经建立,需要整理、转换变量时,碰到的更多情况是需要根据某种条件从原有变量计算新变量。,Transform,菜单主要集中了一些对变量进行变换的过程,如对原始数据进行四则运算、求出变量的秩次等。它们往往在统计分析的预处理起着非常重要的作用,而其中最重要的是,Compute,过程和,Recode,过程。,一、,Compute,过程,【Compute Variable,对话框,】,计算体重指数,选择菜单,Transform=Compute,,弹出,Compute Variable,对话框。左上角为需要计算的变量名,在其中键入新变量名,BMI,;可以用鼠标按中部为类似计算器的软键盘输入体重,/(,身高,身高,),,输入的内容回立刻在右上方的数值表达式窗口中出现,单击“,OK”,按钮系统就会自动生成一个新变量,BMI,。,二、,Recode,过程(重新编码过程),【Recode,对话框,】,Recode,对话框用于从原变量值按照某种一一对应的关系生成新变量值,可以将新值赋给原变量,也可以生成一个新变量。,例:,将,150,名男婴出生体重划分为不同的组段。,对男婴出生体重,X,划分为不同体重范围,结果放在变量,X1,。,将体重划分为不同的范围。,THE END,
    展开阅读全文

    开通VIP折扣优惠下载文档

    提示  咨信网声明:本文档由用户上传并分享,仅供学习交流、研究之用,未经授权,严禁复制、发行、汇编、翻译或网络传播等,侵权必究。

    咨信网小贴示:
    1、浏览或下载可查看了解,请点击【咨信网告知】。
    2、下载文件中如有侵权或不适当内容,将立即纠正。
    3、如果因为网速或其他原因下载失败请重新下载,重复下载[60天内]不扣币。
    4、开具发票登录电脑端申请,请点击【索取发票】。

    咨信网客服组:【微信客服】

    自信AI创作助手
    关于本文
    本文标题:spss-应用简介.ppt
    链接地址:https://www.zixin.com.cn/doc/14665678.html

    Copyright ©2010-2026   All Rights Reserved  宁波自信网络信息技术有限公司 版权所有   |  客服电话:0574-28810668    微信客服:咨信网客服    投诉电话:18658249818   

    违法和不良信息举报邮箱:help@zixin.com.cn    文档合作和网站合作邮箱:fuwu@zixin.com.cn    意见反馈和侵权处理邮箱:1219186828@qq.com   | 证照中心

    12321jubao.png12321网络举报中心 电话:010-12321  jubao.png中国互联网举报中心 电话:12377   gongan.png浙公网安备33021202000488号  icp.png浙ICP备2021020529号-1 浙B2-20240490   


    关注我们 :微信公众号  抖音  微博  LOFTER               

    自信网络  |  ZixinNetwork