第6章 时间轴和行为.ppt
- 配套讲稿:
如PPT文件的首页显示word图标,表示该PPT已包含配套word讲稿。双击word图标可打开word文档。
- 特殊限制:
部分文档作品中含有的国旗、国徽等图片,仅作为作品整体效果示例展示,禁止商用。设计者仅对作品中独创性部分享有著作权。
- 关 键 词:
- 第6章 时间轴和行为 时间 行为
- 资源描述:
-
单击此处编辑母版标题样式,单击此处编辑母版文本样式,第二级,第三级,第四级,第五级,*,第6章 时间轴和行为,6.1,【案例,33,】“体育世界”网页,6.2,【案例,34,】添加游动广告的,“,体育世界,”,网页,6.3,【案例,35,】“跟我学计算机”网页调出式菜单,6.4,【案例,36,】,“,北京名胜,1,”,网页,交替变化图像,6.5,【案例,37,】,“,北京名胜,2,”,网页,弹出窗口,6.6,【案例,38,】,“,图像链接翻转,”,网页,6.7,【案例,39,】,“,跟我学制作表单,”,网页(二),6.8,【案例,40,】,“,控制播放,Flash,动画和,MIDI,音乐,”,网页,6.9,【案例,41,】“活动菜单”网页,6.10,【案例,42,】,“,拼图,”,网页,6.1,【案例,33,】“体育世界”网页,1,“时间轴”面板,单击,“,窗口,”,“,时间轴,”,菜单命令或按【,Alt+F9,】,组合键,即可调出,“,时间轴,”,面板,如图,6-1-4,所示。该面板中的各个工具及其他选项的作用如下。,(,1,),“,时间轴,”,下拉列表框:其内列出了当前页面内所有时间轴动画的名字,选中其中一个选项后,相应的动画就会在,“,时间轴,”,面板中显示出来。右击,“,时间轴,”,面板内部,调出,“,时间轴,”,快捷菜单,单击该菜单中的,“,添加时间轴,”,菜单命令,即可在,“,时间轴,”,下拉列表框内添加一个新的时间轴动画(默认名称为,“,Timeline,”,+,序号)。,(,2,)回放头:播放动画时,它在时间标尺上移动,好像放像机的磁头一样。用鼠标拖曳它在时间标尺上移动,当它移到某一时间单位处时,相应的动画画面就会出现在网页窗口内。,(,3,)【播放】按钮:单击它,可以使动画前进一个帧。按住该按钮不放,可以向正常方向播放动画。,(,4,)【回放】按钮:单击它,可以使动画回退一帧。单击按下该按钮不放,可以向相反方向播放动画。,(,5,)【归位】按钮:将动画图像移到起始位置,同时回放头也移动到该位置处。,(,6,),“,回放头位置,”,(也是当前帧号码)文本框:用来输入显示和设置,“,回放头,”,所处的时间轴位置号,即当前帧号码。,(,7,),“,速率,”,文本框:用来输入每秒钟播放的帧数。,(,8,),“,自动播放,”,复选框:选中它后,则在网上下载后会自动播放。不选中它时,需要在使用行为事件时才可以播放。,(,9,),“,循环,”,复选框:选中它后,则循环播放动画,否则只播放一次动画。,(,10,)动画通道:它由许多图层组成,表示可以在一个页面内加入多个时间轴动画,但最多可以加,32,个。它的左边标有图层的编号,图层编号大的动画在图层编号小的动画之上。,(,11,)动画条:表示一个动画所占的帧数,上面标有该动画所在层的名字。它的起始处和终止处各有一个小圆,表示首帧和终止帧。如果设置了关键帧,则关键帧也会有一个小圆。,(,12,)行为通道左边标有字母,“,B,”,,,可以在该通道的特定帧使用行为。,(,13,)行为帧:加入了行为的帧,它在,“,行为通道,”,内。,(,14,)时间标尺:给出了与时间对应的帧数码。,2,直线移动动画的制作,下面来使用,“,时间轴,”,面板制作一个简单的、沿直线移动的动画。该动画的制作方法如下所述。,(,1,)在页面内插入一个层,给该层起一个名字,例如,“,Layer1,”,。,然后在层内插入一个图像、动画或输入一些文字等。此处层中插入的是,GIF,动画,如图,6-1-6,所示。,(,2,)将插有图像或文字的层移到动画的起始位置。,(,3,)单击,“,窗口,”,“,时间轴,”,菜单命令,调出,“,时间轴,”,面板。,(,4,)用鼠标将层拖曳到,“,时间轴,”,面板的动画通道内,或单击,“,修改,”,“,时间轴,”,“,增加对象到时间轴,”,菜单命令。这时,,“,时间轴,”,面板的动画通道内会出现一个动画条。如果选中了,“,循环,”,复选框,则在动画通道中,会同时出现一个,“,动作帧,”,。,(,5,)单击选中动画条的终止帧。默认的动画帧数是,15,帧,如果要调整动画的帧数,可用鼠标拖曳动画条终止帧的小圆。在改变了终止帧的位置之后,,如果此时选中了,“,循环,”,复选框,还应用鼠标拖曳行为通道的行为帧到终止帧的下一个位置处。用鼠标向右拖曳第,15,帧小圆到第,30,帧处,如图所示。,(,6,)用鼠标拖曳动画层到目标处。当松开鼠标左键时,会看到一条直线,表示图像移动的路径。,在选中,“,循环,”,复选框的情况下,如果先用鼠标拖曳动画层到目标处,再调整,“,时间轴,”,面板中终止帧的位置,则还需要用鼠标拖曳调整,“,动作帧,”,到终止帧的下一帧位置处。,(,7,)按住【播放】按钮不放,即可在网页设计窗口内看到动画。,6.2 【案例34】添加游动广告的“体育世界”网页,“,时间轴,”,面板可以在用户给出起始帧和终止帧后自动产生中间过程的各帧。如果动画的移动路径不是直线的,中间有转折点,则转折点处的画面就是关键帧。加入关键帧,可以使沿直线路径移动的动画变为沿曲线或折线路径移动的动画,添加关键帧的方法如下。,(,1,)单击选中动画条内要加入关键帧的位置,回放头会随之移到此时间位置,同时回放头回移到此处,用来指示选中的位置。例如,选择第,15,帧(将终止帧移到第,30,帧处)。,(,2,)在动画条内,单击鼠标右键,调出时间轴快捷菜单。再单击该菜单内的,“,增加关键帧,”,菜单命令,即可在选中的位置处插入一个关键帧,如图所示。按住【,Ctrl,】,键,单击要加入关键帧的位置,也可以添加关键帧。,如果对关键帧的位置不满意,可以用鼠标拖曳关键帧上的小圆到满意的位置。,如果要删除关键帧,可以单击选中要删除的关键帧,单击鼠标右键,调出时间轴快捷菜单,再单击该菜单中的,“,移除关键帧,”,菜单命令即可。,2,制作沿曲线路径移动的动画,方法,1,:单击选中关键帧,用鼠标拖曳动画层到新的位置,即可确定关键帧图像的位置。此时,动画移动的路径线会变为一条曲线。可以看出,路径线的起始位置与终止位置不变。如果要改变关键帧图像的位置,可以再用鼠标拖曳动画层到新的位置。,按住【播放】按钮不放,即可在网页设计窗口内看到沿曲线路径移动的动画了。,方法,2,:可以用鼠标拖曳的方法来制作沿曲线路径移动的动画,设计过程如下。,在页面内插入一个层,并给该层起一个名字。然后,在层内插入一个图像或输入一些文字等,再将插有图像或文字的层移到动画的起始位置。此处,层中插入的是图像。,单击选中该层,再单击,“,修改,”,“,时间轴,”,“,录制层路径,”,菜单命令,或者单击时间轴快捷菜单中的,“,录制层路径,”,菜单命令。,在网页设计窗口内,,按照希望的曲线路径,用鼠标拖曳层。随着鼠标拖曳的进行,会产生一条曲线路径线。,松开鼠标左键,即可生成复杂曲线路径。此时,“时间轴”面板会自动产生动画条,如图所示。由产生的动画条可以看出,用鼠标拖曳所用的时间越长,组成动画的帧数也越多。鼠标拖曳时的转折点越多,自动产生的关键帧也越多。,按住【播放】按钮不放,即可在网页设计窗口内看到沿曲线路径移动的动画,3,动画的更名、删除、复制和移动,(,1,),动画的更名:,可以直接在,“,时间轴,”,面板的列表框内更改动画的名字。,另外,可以单击时间轴菜单中的,“,重命名时间轴,”,菜单命令,调出,“,重命名时间,轴,”,对话框。在该对话框的,“,时间轴名称,”,文本框内输入新的名字,再单击【确定】按钮即可。,(,2,)动画的删除:动画的删除方法如下。,删除动画条:单击选中要删除的动画条,按【,Delete,】,键或单击,“,编辑,”,“,剪切,”,菜单命令。,删除所有动画条:单击时间轴菜单中的,“,移除时间轴,”,菜单命令。,(,3,)动画的复制:动画的复制方法如下。,单击选中要复制的动画条,再单击时间轴菜单中的,“,拷贝,”,菜单命令。,调整回放头的位置,再单击时间轴菜单中的,“,粘贴,”,菜单命令,即可在选中的动画条的右边复制一个动画条。而且可以粘贴到其他页面的,“,时间轴,”,面板中。,(,4,)动画的移动:动画的移动方法如下。,方法一:单击选中要移动的动画条,再单击时间轴菜单中的,“,剪切,”,菜单命令。调整回放头的位置,再单击时间轴菜单中的,“,粘贴,”,菜单命令,即可将动画条移到回放头所处的位置处,而且可以移动到其他页面的,“,时间轴,”,面板中。,方法二:,可以用鼠标拖曳一个动画条在整个动画通道内移动。按住【,Shift,】,键,单击要移动的动画条,选中多个动画条,鼠标拖曳选中的动画条,即可同时移动多个动画条。,6.3 【案例35】“跟我学计算机”网页调出式菜单,1,动作名称及其作用,行为是动作(,Actions,),和事件(,Events,),的组合。动作就是计算机系统执行的一个动作,例如,调出一个提示框、执行一段程序或一个函数、播放声音或影片、启动或停止,“,时间轴,”,面板中的动画等。动作通常是由预先编写好的,JavaScript,程序脚本实现的,,Dreamweaver,8,自带了一些动作的,JavaScript,程序脚本,可供用户直接调用。用户也可以自己用,JavaScript,语言编写,JavaScript,程序脚本,创建新的行为。,事件是指引发动作产生的事情,例如,鼠标移到某对象之上、鼠标单击某对象、,“,时间轴,”,面板中的回放头播放到某一帧等。要创建一个行为,就是要指定一个动作,再确定触发该动作的事件。有时,某几个动作可以被相同的事件触发,则须要指定动作发生的顺序。,Dreamweaver,8,采用了,“,行为,”,面板(也叫,“,行为控制器,”,)来完成行为中的动作和事件的设置,从而实现动态交互效果。,单击,“,窗口,”,“,行为,”,菜单命令或按【,Shift+F3,】,组合键,即可调出,“,行为,”,面板。,单击,“,行为,”,面板中的,“,添加行为,”,按钮,调出,“,动作名称,”,菜单,其作用如,表所示。再单击某 一个动作名称,即可进行相应的动作设置。,动作名称及动作的作用,序号,动作的英文名称,动作的中文名称,动作的作用,1,Swap Image,交换图像,交换图像,2,Popup Message,调出信息,调出消息栏,3,Swap Image Restore,恢复交换图像,恢复交换图像,4,Open Browser Window,打开浏览器窗口,打开新的浏览器窗口,5,Drag Layer,拖动层,拖曳层到目标位置,6,Control Shockwave or Flash,控制,Shockwave,或,Flash,控制,Shockwave,或,Flash,影像,7,Play Sound,播放声音,播放声音,8,Change Property,改变属性,改变对象的属性,9-1,Play Timeline,时间轴(播放时间轴),播放时间轴上的动画,9-2,Stop Timeline,时间轴(停止时间轴),停止时间轴上动画的播放,9-3,Go To Timeline Frame,时间轴(转到时间轴帧),跳转到时间轴上的某一帧,10,Show-Hide Layers,显示,隐藏层,显示或隐藏层,11,Show-Menu,显示调出菜单,为图像添加调出菜单,序号,动作的英文名称,动作的中文名称,动作的作用,12,Check,Plugin,检查插件,检查浏览器中已安装插件的功能,13,Check Browser,检查浏览器,检查浏览器的类型和型号,以确定显示的页面,14,Validate Form,检查表单,检查指定的表单内容的数据类型是否正确,15,Set,Nav,Bar Image,设置导航栏图像,设置引导链接的动态导航条图像按钮,16-1,Set Text of Layer,设置文本(设置层文本),设置层中的文本,16-2,Set Text of Frame,设置文本(设置框架文本),设置框架中的文本,16-3,Set Text of Text Field,设置文本(设置文本域文字),设置表单域内文字框中的文字,16-4,Set Text of Status Bar,设置文本(设置状态条文本),设置状态栏中的文本,17,Call JavaScript,调用,JavaScript,调用,JavaScript,函数,18,Jump Menu,跳转菜单,选择菜单实现跳转,19,Jump Menu Go,跳转菜单开始,选择菜单后,单击【,Go,】,按钮实现跳转,20,Go To URL,转到,URL,跳转到,URL,指定的网页,21,Preload Images,预先载入图像,预装载图像,以改善显示效果,22,Get More Behaviors,获得更多行为,上网,获得更多行为(不属于动作),注意:,对于选择不同的浏览器,可以使用的动作也不一样,版本低的浏览器可以使用的动作较少。当选定的对象不一样时,动作名称菜单中可以使用的动作也不一样。,进行完动作的设置后,在,“,行为,”,面板的列表框内会显示出动作的名称与默认的事件名,称。可以看出,在选中动作名称后,“事件”栏中默认的事件名称右边会出现一个按钮。,2,事件名称及其作用,如果要重新设置事件,可单击“事件”栏中默认的事件名称右边的按钮,调出事件名称菜单。菜单中列出了该对象可以使用的所有事件。,各个事件的名称及其作用如表所示。,序号,事,件,名,称,事件可以作用的对象,事件的作用,1,OnAbort,图像、页面等,中断对象载入操作时,2,onAfterUpdate,图像、页面等,对象更新之后,3,onBeforeUpdate,图像、页面等,对象更新之前,4,onFocus,按钮、链接和文本框等,当前对象得到输入焦点时,5,onBlur,按钮、链接和文本框等,焦点从当前对象移开时,序号,事,件,名,称,事件可以作用的对象,事件的作用,6,onClick,所有对象,单击对象时,7,onDblClick,所有对象,双击对象时,8,onError,图像、页面等,载入图像等当中产生错误时,9,onHelp,图像等,调用帮助时,10,onLoad,图像、页面等,载入对象时,11,onMouseDown,链接图像和文字等,在链接文字或图像处按下鼠标左键时,12,onMouseUp,链接图像和文字等,在链接文字或图像处松开鼠标左键时,13,onMouseOver,链接图像和文字等,鼠标指针移入链接文字或图像区域时,14,onMouseOut,链接图像和文字等,鼠标指针移出链接文字或图像区域时,15,onMouseMove,链接图像和文字等,鼠标指针在链接文字或图像上移动时,16,onReadyStateChange,图像等,对象状态改变时,17,onKeyDown,链接图像和文字等,当焦点在对象上,按键处于按下状态时,序号,事,件,名,称,事件可以作用的对象,事件的作用,18,onKeyPress,链接图像和文字等,当焦点在对象上,按键按下时,19,onKeyUp,链接图像和文字等,当焦点在对象上,按键抬起时,20,onSubmit,表单等,表单提交时,21,onReset,表单等,表单重置时,22,onSelect,文字段落、选择框等,选定文字段落或选择框内某项时,23,onUnload,主页面等,当离开此页时,24,onResize,主窗口、帧窗口等,当浏览器内的窗口大小改变时,25,onScroll,主窗口、帧窗口、多行输入文本框等,当拖曳浏览器窗口的滚动条时,26,onRowEnter,Shockwave,等,动画载入时,27,OnRowExit,Shockwave,等,动画卸载时,注意:,如果出现带括号的事件,则该事件是链接对象的。使用它们时,系统会自动在行为控制器下拉列表框内显示的事件名称前面增加一个“,#,”号,表示空链接。,3,设置行为的其他操作,(,1,)选择行为的目标对象:要设置行为,必须先选中事件作用的对象。单击选中图像、用鼠标拖曳选中文字等,都可以选择行为的目标对象。另外,也可以单击网页设计窗口左下角状态栏上的标记,来选中行为的目标对象。例如,要选中整个页面窗口,可单击,标记。还可以单击页面空白处,再按【,Ctrl+A,】,组合键。,选中不同的对象后,,“,标签,”,面板的标题栏名称会随之发生变化。,“,标签,”,面板的标题栏的名称中将显示行为的对象名称,例如,选择整个页面窗口后,,“,标签,”,面板的名称为,“,标签,”,。,(,2,),显示所有事件:,单击,“,行为,”,面板中的【显示所有事件】按钮 ,在,“,行为,”,面板中会显示出选中对象所能使用的所有事件。单击【显示设置事件】按钮 后,在,“,行为,”,面板中只显示已经使用的事件。,(,3,)单击选中,“,行为,”,面板内的某一个行为项(即动作和事件)时,再单击按钮 ,即可删除选中的行为项。,(,4,)单击选中,“,行为,”,面板内的某一个行为项后,再单击 按钮,可以使选中的行为的执行次序提前,单击选中行为项后,再单击 按钮,可以使选中的行为,执行次序下降。,4,“显示隐藏层”动作,选中层以后,在,“,行为,”,面板中选择,“,显示,隐藏层,”,菜单命令,可以调出,“,显示,隐藏层,”,对话框。,(,1,)如果要设置层为显示状态,则单击选中,“,命名的层,”,列表框内层的名称,再单击【显示】按钮,此时,“,命名的层,”,列表框内选中的层名称右边会出现,“,(显示),”,文字。,(,2,)如果要设置层为不显示状态,则单击选中,“,命名的层,”,列表框内层的名称,再单击【隐藏】按钮,此时,“,命名的层,”,列表框内选中的层名称右边会出现,“,(隐藏),”,文字。,(,3,)单击【默认值】按钮后,可将层的显示与否设置为默认状态。,6.4,【案例,36,】,“,北京名胜,1,”,网页,交替变化图像,1,“调出信息”动作,选择整个页面,单击,“,行为,”,面板中的 按钮,调出,“,动作名称,”,菜单,单击选择,“调出信息”,菜单命令,调出,“,调出信息,”,对话框。在,“,消息,”,文本框内输入调出的对话框内要显示的文字,单击【确定】按钮,即可完成动作设置。,2,“设置文本”动作,选择一个页面对象,单击,“,行为,”,面板中的 按钮,调出,“,动作名称,”,菜单,单击选择,“,设置文本,”,菜单命令,调出它的子菜单,各子菜单命令的作用如下所述。,(,1,)设置状态条文本:选择整个页面,单击,“,行为,”,面板中的 按钮,再单击选择,“,设置文本,”,“,设置状态栏文本,”,菜单命令,会调出,“,设置状态栏文本,”,对话框。在,“,消息,”,文本框内输入要在状态栏中显示的文字,然后单击【确定】按钮。,(,2,)设置层文本:选择一个层,单击,“,行为,”,面板中的 按钮,单击选择,“,设置文本,”,“,设置状态栏文本,”,菜单命令,调出,“,设置层文本,”,对话框。利用该对话框,可以在指定的层中建立一个文本域。该对话框中各选项的作用如下。,“,层,”,下拉列表框:,选择层的名称。,“,新建,HTML,”,文本框:可以输入发生事件后,在选定层内显示的文字内容,该内容包括任何有效的,HTML,源代码。,(3)设置框架文本:在创建框架后,选中一个框架,单击,“,行为,”,面板中的按钮 ,再单击选择,“,设置文本,”,“,设置框架文本,”,菜单命令,调出,“,设置框架文本,”,对话框。利用该对话框,可以在选中的框架内建立一个文本域。该对话框中各选项的作用如下。,“,框架,”,下拉列表框:用来选择分栏框架窗口的名称。,“,新建,HTML,”,文本框:可以在此文本框内输入发生事件后,在选定的分栏框架窗口内显示的文字内容,该内容包括任何有效的,HTML,源代码。,【,获得当前,HTML,】,按钮:单击它后,在,“,新建,HTML,”,文本框内会显示出选中的分栏框架窗口内网页的,HTML,地址。,“,保留背景颜色,”,复选框:选择它后,可以保存背景色。,(,4,)设置文本域文字:先创建表单域内的文本框,并命名,单击,“,行为,”,面板中的 按钮,再单击选择,“,设置文本,”,“,设置文本域文字,”,菜单命令,调出,“,设置文本域文字,”,对话框,如图所示。,在该对话框的,“,文本域,”,下拉列表框内选择文本域,再在,“,新建文本,”,文本框内输入文本。然后,单击【确定】按钮,退出,“,设置文本域文字,”,对话框。,6.5,【案例,37,】,“,北京名胜,2,”,网页,弹出窗口,1,“打开浏览器窗口”动作,单击,“,行为,”,面板中的按钮,调出,“,动作名称,”,菜单,单击选择,“,打开浏览器窗口,”,菜单命令,调出,“,打开浏览器窗口,”,对话框。,(,1,),“,要显示的,URL,”,文本框与【浏览】按钮:在文本框内输入新打开的浏览器窗口内要显示的网页文件地址或单击【浏览】按钮后,选择网页文件。,(,2,),“,窗口宽度,”,与,“,窗口高度,”,文本框:设定浏览器窗口的宽度和高度。,(,3,),“,属性,”,栏:用来定义浏览器窗口的属性。,选中,“,导航工具栏,”,复选框,表示保留浏览器的导航工具栏。,选中,“,菜单栏,”,复选框,表示保留浏览器的主菜单。,选中,“,地址工具栏,”,复选框,表示保留浏览器的地址栏。,选中,“,需要时使用滚动条,”,复选框,表示根据需要给浏览器的显示窗口加滚动条。,选中,“,状态栏,”,复选框,表示给浏览器的显示窗口下边加状态栏。,选中,“,调整大小手柄,”,复选框,表示可以用鼠标拖曳调整浏览器显示窗口的大小。,(,4,),“,窗口名称,”,文本框:输入新的浏览器窗口的名称。,2,“改变属性”动作,单击,“,行为,”,面板中的 按钮,调出,“,动作名称,”,菜单,单击选择,“,改变属性,”,菜单命令,调出,“,改变属性,”,对话框。,(,1,),“,对象类型,”,下拉列表框:用来选择对象在,HTML,文件中所用的标记。例如,可选择,标记。,(,2,),“,命名对象,”,下拉列表框:用来选择对象的名字。对象的名字是在它的,“,属性,”,栏内输入的。,(,3,),“,属性,”,栏:在选择了,“,选择,”,单选按钮后,可以选择要改变对象的属性名字,即它的标识符属性名称。在选择了,“,输入,”,单选按钮后,可在其右边的文本框内输入属性,名字。例如,在“对象类型”下拉列表框内选择了,标记,则“选择”下拉列表框内显示的内容如图所示。“属性”栏右边的下拉列表框用来选择浏览器。,在图所示的下拉列表框内给出了各种样式的名称。如果选择了,“,innerHTML,”,选项,则可以对,HTML,语言的内容进行替换;如果选择了,“,innerText,”,选项,则可以对文,本内容进行替换。,(,4,),“,新的值,”,文本框:用于输入属性的新值。,6.6,【案例,38,】,“,图像链接翻转,”,网页,1,“设置导航栏图像”动作,在页面中插入导航栏或图像,单击,“,行为,”,面板中按钮的右下角箭头,调出,“,动作名称,”,菜单。单击选择,“,设置导航栏图像,”,菜单命令,调出,“,设置导航栏图像,”,对话框。,(,1,)选择,“,基本,”,标签后的,“,设置导航栏图像,”,对话框,其中各选项的作用如下。,“,项目名称,”,文本框:输入此动态图像按钮的名称。,4,个文本框与【浏览】按钮:定义鼠标,4,种状态时的图像。,“,状态图像,”,是正常状态(静态)下的图像,,“,鼠标经过图像,”,是鼠标移到图像之上时的图像,,“,按下图像,”,是鼠标单击图像时的图像,,“,按下时鼠标经过图像,”,是鼠标按下并拖曳鼠标指针经过图像的过程中的图像。,“,按下时,前往的,URL,”,栏:在文本框内可输入与导航图像链接的页面文件的目录和文件名,单击【浏览】按钮后可选择链接的文件,其右边的下拉列表框内可选择显示链接的页面的打开方式。,“,选项,”,栏:,“,预先载入图像,”,复选框用来确定是否要预先载入各个图像,,“,最初显示,按下图像,”,复选框用来确定是否要在初始状态下显示,“,按下图像,”,状态时的图像。,(,2,)单击,“,高级,”,标签后的,“,设置导航栏图像,”,对话框。它用来进行改变其他图像内容的设置。该对话框内各选项的作用如下所述。,最上边的下拉列表框:用来选择鼠标动作的状态。选择,“,鼠标经过图像或点击时鼠标经过图像,”,选项,表示鼠标处于移到图像之上或鼠标按下的过程中;选择,“,点击图像,”,选项,表示鼠标处于按下的状态。选择第,2,个选项时,其下边的,“,按下时,变成图像文件,”,文本框与【浏览】按钮消失。,“,同时设置图像,”,列表框:该列表框内列出当前页面内的所有图像的名字。单击选择一个图像名字后,表示可以对该图像进行图像转换。列表框名字中的,“,PHOTO1,”,、,“,PHOTO2,”,和,“,PHOTO3,”,表示动态图像初始状态(即静态)时的图像名字,即动态图像的名字。,“,变成图像文件,”,文本框与【浏览】按钮:用来选择一幅图像,当鼠标指针经过动态图像时,,“,同时设置图像,”,列表框中选中的图像将转变为该图像。,“,按下时,变成图像文件,”,文本框与【浏览】按钮:用来选择一幅图像,当单击动态图像时,,“,同时设置图像,”,列表框中选中的图像将转变为该图像。,2,“交换图像”动作,单击选择,“交换图像”菜单命令,,调出,“,交换图像,”,对话框。其中,各选项的作用如下。,(,1,),“,图像,”,列表框:用来选择图像的名称。,(,2,),“,设置原始档为,”,文本框与【浏览】按钮:输入或选择要更换的图像。,(,3,),“,预先载入图像”复选框:选择它后,可以预先载入图像,使网页的显示更流畅。,(,4,),“,鼠标滑开时恢复图像,”,复选框:选择它后,可以在鼠标指针离开时恢复图像。,如果要更换多幅图像,可重复进行上述的设置。,3,“恢复交换图像”动作,它的作用是恢复交换的图像。单击选择,“,恢复交换图像,”,菜单命令后,会调出,“,恢复交换图像,”,提示框。再单击【确定】按钮,即可完成恢复图像动作的设置。通常它与交换图像动作配合使用,,“,恢复交换图像,”,提示框的显示效果。,6.7 【案例39】“跟我学制作表单”网页(二),1,“检查表单”动作,如果建立了一个表单域(名字为,“,form1,”,),,再在表单域内创建,3,个文本字段(名字分别为:,“,textfield1,”,、,“,textfield2,”,和,“,textfield3,”,)。,然后,选择表单域,再单击选择,“检查表单”菜单命令,,即可调出,“,检查表单,”,对话框。利用该对话框,可以检查指定的表单内容的数据类型是否正确,可以对表单内容设置检查条件。在用户提交表单内容时,先根据设置的条件,检查提交的表单内容是否符合要求。如果符合要求,则上传到服务器,否则显示错误提示信息。该对话框内各选项的作用如下所述。,(,1,),“,命名的栏位,”,列表框:列出表单内的所有文本框的名称,可以选择其中一个进行下面的设置。设置完后,可以选择另外一个,再进行下面的设置。,(,2,),“,值,”,复选框:选中它后,表示文本框内不可以是空的。,(,3,),“,可接受,”,栏:它用来选择接收内容的类型,各选项的含义如下所述。,“,任何东西,”,单选按钮:表示接受不为空的内容。,“,数字,”,单选按钮:表示接受的内容只可以是数字。,“,电子邮件地址,”,单选按钮:表示接受的内容只可以是电子邮件地址形式的字符串。,“,数字从,”,单选按钮:,用来限定接受的数字范围。其右边的两个文本框用来输入起始数据和终止数据。,2,“检查插件”动作,在网页中会使用一些需要外部插件才能观看的动态效果(例如:,Shockwave,、,Flash,、,QuickTime,、,LiveAudio,和,Windows Media Players,等),如果浏览器中没有安装相应的插件,则会显示出空白。此时,为了不出现空白,可用简单的画面代替。单击选择,“,检查插件,”,菜单命令后,会调出,“,检查插件,”,对话框,如图所示。利用该对话框,可以增加检查浏览器中已安装插件的功能。该对话框内各选项的作用如下。,(,1,),“,插件,”,栏:在,“,选择,”,下拉列表框内选择要检测的插件名称,也可以在,“,输入,”,文本框内输入列表框内没有的插件名称。,(,2,),“,如果有,转到,URL,”,文本框:对有该插件的浏览器,采用该文本框内,URL,指示的网页。可以通过单击【浏览】按钮后选择网页文档。,(,3,),“,否则,转到,URL,”,文本框:对没有该插件的浏览器,采用该文本框内,URL,指示的网页。网页文件也可通过单击【浏览】按钮选择网页文档。,(,4,),“,如果无法检测,则始终转到第一个,URL,”,复选框:如果使用的是,和,标记,必须选中该复选框,因为该标记可以在用户没有,ActiveX,控件的情况下自动下载。,3,“检查浏览器”动作,网页在不同的浏览器内会有不同的显示结果。为了解决这个问题,利用,Dreamweaver,8,可以针对不同的浏览器进行网页设计。但要使多个浏览器在显示网页时都能正常显示,必须使用,“,检查浏览器,”,动作。该动作可以根据识别出的浏览器类型和版本,发送不同的网页(这个网页是专门为这种浏览器设计的)。单击选择,“,检查浏览器,”,菜单命令后,会调出,“,检查浏览器,”,对话框。,(,1,),“,Netscape Navigator,:,”,栏:用来选择,Netscape Navigator,类型浏览器。以其文本框内的版本号(例如,Netscape Navigator 4.0,),为界,对于该版本号及其以后的版本号的浏览器,显示由,“,或更新的版本,”,下拉列表框选项决定的网页;对于该版本号以前的浏览器,显示由,“,否则,,”,下拉列表框选项决定的网页。两个下拉列表框的选项一样,都有,3,个,其作用如下所述。,留在此页:停留在当前页面。,转到,URL,:,跳转到下边,“,URL,”,文本框内指示的网页。,前往替代,URL,:,跳转到下边“替代,URL,”,文本框内指示的网页。,(,2,)“,Internet Explorer,”,栏:用来选择,Internet Explorer,类型浏览器。,(,3,)“其他浏览器”列表框:用来决定其他浏览器要显示的网页。,(,4,)“,URL,”,和“替代,URL,”,文本框与【浏览】按钮:分别选择两个网页,以适应不同的浏览器版本。可以在文本框内输入网页的,URL,,,也可以单击【浏览】按钮来选择。,6.8 【案例40】“控制播放,Flash,动画和,MIDI,音乐”网页,1,“控制,Shockwave,或,Flash,”,动作,在页面内插入,Shockwave,或,Flash,动画(文件格式是,SWF,,,播放器的版本应该是,Flash Player 6,),的情况下,单击选择,“,控制,Shockwave,或,Flash,”,菜,单命令,,调出,“,控制,Shockwave,或,Flash,”,对话框。,(,1,),“,影片,”,下拉列表框:用来选择,Shockwave,或,Flash,影像的名字。,(,2,),“,动作,”,栏:该栏有,4,个单选按钮,分别是,“,播放,”,、,“,停止,”,、,“,后退,”,和,“,前往帧,”,(即转到影像的一帧播放)。选择,“,前往帧,”,单选按钮后,还应在其右边的文本框内输入帧的编号。,2,“播放声音”动作,单击,“,行为,”,面板中的 按钮,调出,“,动作名称,”,菜单,单击选择,“,播放声音,”,菜单命令,调出,“,播放声音,”,对话框。在,“,播放声音,”,文本框内输入声音文件的名字,或者单击【浏览】按钮后选择声音文件。再单击【确定】按钮,即可完成动作设置。,3,“调用,JavaScript,”,动作,单击选择该动作名称后,会调出,“,调用,JavaScript,”,对话框。在该对话框的,“,JavaScript,”,文本框内输入,JavaScript,函数,再单击【确定】按钮,即可完,成动作设置。,JavaScript,函数可以是系统自带的,也可以是自己编写的。,6.9,【案例,41,】,“,活动菜单,”,网页,1,“时间轴”动作,单击,“,时间轴,”,菜单命令,可以调出它的子菜单,各子菜单命令的作用如下所述。,(,1,)播放时间轴:单击选择该动作名称后,会调出,“,播放时间轴,”,对话框,。在,“,播放时间轴,”,下拉列表框内选择时间轴动画的名称,再单击【确定】按钮,即可完成使指定时间轴动画播放的动作设置。,(,2,)停止时间轴:单击选择该动作名称后,会调出,“,停止时间轴,”,对话框,如图所示。在,“,停止时间轴,”,下拉列表框内选择时间轴动画的名称,再单击【确定】按钮,即可完成使指定时间轴动画停止播放的动作设置。,(,3,)转到时间轴帧:单击选择该动作名称后,会调出,“,转到时间轴帧,”,对话框。,“,时间轴,”,列表框:用来选择要控制的时间轴名称。,“,前往帧,”,文本框:输入要跳转的帧号码。事件发生后,时间轴内的回放头会自动移到该帧,继续往下播放。,“,循环,”,文本框:用来输入循环播放的次数。它的设置只有在时间轴上的某一帧为引发事件的对象时才有效。,(,4,)设置在动画的一段中循环播放的方法如下所述。,在时间轴控制面板中创建一个动画,再在某一帧处单击鼠标右键,调出它的快捷菜单,再单击,“,添加行为,”,菜单命令,设置该帧为行为帧。,回到行为控制器,可以在标题栏内看到当前的对象就是该时间轴动画。单击行为控制器内的 按钮,再调出,“,转到时间轴帧,”,对话框,进行循环次数的设置和跳转的帧号码的设置。最后,单击【确定】按钮,即可完成动作设置。,2,“转到,URL,”,动作,在设置框架后,单击选择该动作名称,调出,“,转到,URL,”,对话框,如图,6-9-10,所示。利用该对话框,可以指定要跳转到的,URL,网页。该对话框中各选项的作用如下。,(,1,),“,打开在,”,显示框:显示出框架的名称,用来选择显示跳转页面的框架。,(,2,),“,URL,”,文本框与【浏览】按钮:在文本框内输入链接的网页的,URL,,,也可以单击【浏览】按钮,选择链接的网页文件。,6.10,【案例,42,】,“,拼图,”,网页,1,“拖动层”动作,在页面内插入层后,单击选择该动作名称,调出,“,拖动层,”,对话框。,(,1,)选择,“,基本,”,标签后的,“,拖动层,”,对话框。该对话框内各选项的作用如下所述。,“,层,”,下拉列表框:选择要拖曳的层的名字。,“,移动,”,下拉列表框:选择,“,不限制,”,,,“,层,”,可以在页面内任意移动。选择,“,限制,”,后,在其右边会增加,4,个文本框,用来输入上、下、左和右的数字,形成层移动的限制区域。,“,放下目标,”,栏:在,“,左,”,和,“,上,”,文本框内输入数据(相对于浏览器的左上角),以确定拖曳层移动的目标位置。单击【取得目前位置】按钮,可以将选定层的当前,位置数值自动填入上述两个文本框内。,“,靠齐距离:,”,文本框:输入一个数据,当层移动到的位置与目标位置小于该数据时,层会自动定位到目标位置。否则,层将移回原位置。可见,该文本框内的数值越大,越容易将层拖曳到目标位置。,(,2,)选择,“,高级,”,标签后的,“,拖动层,”,对话框如图所示,该对话框内各选项的作用如下所述。,“,拖曳控制点,”,下拉列表框:用来选择被拖曳的层内单击点的区域。选择,“,整个层,”,,可以拖曳层的任何地方;选择,“,层内区域,”,后,会在其右边出现,4,个文本框,用来输入左、上、宽和高的数字,以形成层的限制区域。,“,拖曳时,”,栏:选中,“,将层移至最前,然后,”,复选框后,表示拖曳层在最上方显示。拖曳层后,层的显示顺序由其右边的列表框中的选项来决定。选择,“,留在最上方,”,选项后,层在顶部显示;选择,“,恢复,Z,轴,”,选项后,可恢复层原来的显示级别。,“,呼叫,J展开阅读全文

咨信网声明:本文档由用户上传并分享,仅供学习交流、研究之用,未经授权,严禁复制、发行、汇编、翻译或网络传播等,侵权必究。
咨信网小贴示:
1、浏览或下载可查看了解,请点击【咨信网告知】。
2、下载文件中如有侵权或不适当内容,将立即纠正。
3、如果因为网速或其他原因下载失败请重新下载,重复下载[60天内]不扣币。
4、开具发票登录电脑端申请,请点击【索取发票】。
咨信网客服组:【微信客服】
1、浏览或下载可查看了解,请点击【咨信网告知】。
2、下载文件中如有侵权或不适当内容,将立即纠正。
3、如果因为网速或其他原因下载失败请重新下载,重复下载[60天内]不扣币。
4、开具发票登录电脑端申请,请点击【索取发票】。
咨信网客服组:【微信客服】


第6章 时间轴和行为.ppt
















自信AI助手














微信客服
客服QQ
发送邮件
意见反馈



链接地址:https://www.zixin.com.cn/doc/14013696.html